Jump to content

Hd500 Repaired But Now Foot Switches Don't Work


Williamlavon
 Share

Recommended Posts

Hello,

Just got the HD500 back from the shop where it had an internal power supply problem repaired.

So now it "works" but the footswitches don't do anything - you can tap them all day and nothing changes.

Turning the Presets knob will change the presets but not the switches and the pedal doesn't do anything either.

I held the Left button down while powering up and that didn't help. Any ideas?

Thanks

Link to comment
Share on other sites

Sounds like the left a ribbon cable unplugged inside.  You can crack it open yourself by removing all the outer edge screws and looking for a cable unattached, or you can take it back to the shop and let them do it.  A ribbon cable disconnected is my guess.  I believe if you do it yourself it voids the warranty though.  How old is your HD?

  • Upvote 1
Link to comment
Share on other sites

It is only a few screws and no seal so long as you have correct fitting philips head screwdriver attachment to your screw gun will take 2 mins. Goes back easy too as everything is fixed inside. No way to say if still under warranty that it has been unsealed, so long as you don't leave tell tale marks on the screws with ill fitting driver LOLOL.

You'l find the ribbon cable. It'l be obvious. and is my guess too, no need to boot her up and test before reassembly. Just reassemble as you found it.

  • Upvote 1
Link to comment
Share on other sites

  • 3 years later...

Thanks for the above. I had the same problem with a 6 year old HD500, after bringing mine up a staircase on a hand truck with other equipment too many times to count. The ribbon connector had worked loose. It took all of 5 minutes to fix.

  • Upvote 1
Link to comment
Share on other sites

Yup all above right. 

 

Around 5-8 mins fix . Depending on how good you are with the Phillips screwdriver . :)   

 

IF this indeed is a cable not plugged in to the main circuit board then undo all the screws ( leaving two in the middle done up cos they only hold the inside reinforcement bar ) then locate the TAPE style looking wire and reconnect to the main board. Make sure you lick the metal water tap before the job to get rid of the static electricity from your body .STATIC  can easily damage the CPU's and other components !!! Try not touching the inside elements as well !  

 

JOB DONE!!!    

 

Respect 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...