Jump to content
Sign in to follow this  
esp79

POD HD500X not being recognised by PC

Recommended Posts

Hi,

​Is anyone having issues with their POD HD not being recognised by their PC?

​This seemed to happen overnight, and I hadn't changed any settings.  When I run Line 6 Monkey it can't pick up the HD500X and although I've installed the latest drivers, it just doesn't seem to work.

​All my other Line 6 gear is being recognised perfectly (even my UX8 which is a lot older!).

​Any help, greatly appreciated!

​Thanks

Share this post


Link to post
Share on other sites

you can try this:

 

for 32 bits  http://www.nirsoft.net/utils/usbdeview.zip

for 64 bits  http://www.nirsoft.net/utils/usbdeview-x64.zip

 

just unzip and launch with admin rights

 

AT FIRST UNPLUG YOUR POD 

Launch USB DEVIEW

Locate YOUR POD (if in list)

RIGHT CLICK and choose UNINSTALL this device

Reboot pc

plug the POD AGAIN

 

Hope it help you

Share this post


Link to post
Share on other sites

My POD HD500 is not detected in my windows 10 64bit pc.  I tried this and it didn't work as I wouldn't expect it would as the POD has never connected.  I bought it used.  I'm thinking maybe it is the USB port on the POD as I've read they can be an issue, but then again my computer detects something, it just says USB detection error.  So it knows something is there, but it just won't install.  Monkey doesn't show anything connected or drivers installed.  I have tried manually downloading the drivers and installing them, but my computer says that is not a valid driver for the device.  I'm at a loss. C:\Program Files (x86)\Line6\Tools\Driver Archive\POD HD 500

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×