Jump to content
ShredIbanez

Flipped LCD Screen

Recommended Posts

Pretty odd.  I went to change a patch and my LCD screen flipped backwards.  Now everything in any screen is backwards on my LCD screen only.  Scribble strips are good.  All the buttons under the LCD screen still think everything is normal so they adjust the parameters originally associated with them but not the parameter newly above the knob.  The joystick also is reverse sensing, i.e. left is right now.

 

Did I hit some magic combination of buttons to cause this?  How do I go back?

Share this post


Link to post
Share on other sites

Looks like some sort of internationalization mode (for use with right to left languages such as Hebrew or Arabic)... but obviously without the text translated.

 

I wonder how you did this wackiness.

Share this post


Link to post
Share on other sites

There's one for support, for sure.

 

I hate to be a Chicken Little, but either the stars are misaligned big time lately, or the latest firmware has an impressive collection of bugs and instabilities.

 

Knock silicon, my Helix has been quite stable on 201, and I've seen all manner of nonsense show up for various people with 210. Sticking w 201 until this settles out. All God's children got bugs, but really, this is too much.

 

I wonder how this happened.

Share this post


Link to post
Share on other sites

Try looking at / photographing the screen directly rather than in the mirror. :lol: :P  (jk of course)

Share this post


Link to post
Share on other sites

Hmm... I have to believe this is some sort of weird hardware issue, but I guess it would be worth trying to re-install the latest firmware.

Share this post


Link to post
Share on other sites

I just restarted my Helix and noticed that for a couple seconds, the screen is actually normal.  Then it flips again...

 

No cats or Queen of Hearts.  But, I did put in a trouble ticket.  My guess is I'll be out a Helix for a month or so.  FML.

 

I just want to point out, I have had basically no issues with this Helix and I got it as soon as it came out.  I love this thing.

Share this post


Link to post
Share on other sites

I just restarted my Helix and noticed that for a couple seconds, the screen is actually normal.  Then it flips again...

 

No cats or Queen of Hearts.  But, I did put in a trouble ticket.  My guess is I'll be out a Helix for a month or so.  FML.

 

I just want to point out, I have had basically no issues with this Helix and I got it as soon as it came out.  I love this thing.

 

Have you tried re-flashing it?

Share this post


Link to post
Share on other sites

Have you tried re-flashing it?

Would that be different than using the Updater to update Firmware?  I've done that twice now to 2.10 with no love.

Share this post


Link to post
Share on other sites

Would that be different than using the Updater to update Firmware?  I've done that twice now to 2.10 with no love.

No different. That's what re-flashing means.

Share this post


Link to post
Share on other sites

Would that be different than using the Updater to update Firmware?  I've done that twice now to 2.10 with no love.

 

That is truly wacky! Opposites Day and Bizarro World. Pretty sure it won't make a difference as I suspect this is a hardware failure, but have you also tried doing a safe boot (FS 6&12) and then updating the firmware again while in safe boot mode? 

Share this post


Link to post
Share on other sites

...sounds like a wonky ribbon cable connection from board to LCD.

Share this post


Link to post
Share on other sites

My apologies for associating this unique glitch with the 210 firmware. I had no evidence, just worry, and since reverting to older firmware doesn't fix it, it's pretty clear they're unrelated.

 

Carry on.

Share this post


Link to post
Share on other sites

Sucks that you have a problem with your Helix. But hey, at least it's something original.

 

Have you been using CC128 lately (see the last page of the manual)?

Share this post


Link to post
Share on other sites

This has got to be, by far, the most bizarrely creative HELIX bug I've heard about!!

Share this post


Link to post
Share on other sites

...sounds like a wonky ribbon cable connection from board to LCD.

Agreed. Exactly what I was about to suggest.

Share this post


Link to post
Share on other sites

Nothing worked from Line 6 suggestions.  However, I turned it on after 2 days of being off.  Guess what...it is back to normal.  Very weird.

Share this post


Link to post
Share on other sites

Nothing worked from Line 6 suggestions.  However, I turned it on after 2 days of being off.  Guess what...it is back to normal.  Very weird.

 

You home doesn't sit across the equatorial line by any chance, does it?  :D

Share this post


Link to post
Share on other sites

...see if heat affects it (like after its been on for some time). Or vibration (give it some light taps on the sides).

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...