Jump to content

Update 2.12 Freezes Helix Every So Often


GaryT898
 Share

Recommended Posts

Hi all,

 

I was real reluctant to update my Helix to 2.12, but I did and now every once in a while, it freezes. Has anyone else had this issue? and what is the fix? Am i going to have re-load it? What a pain this was in the first place and I kind of wished I never did the update. 

Link to comment
Share on other sites

I see these posts periodically regarding Helix freezes. In the past they were usually related to specific problematic presets. This assumes the freezes are not related to the global reset not being executed after a firmware update or an Editor version that is mismatched to the firmware version.  Does this happen on multiple presets? Does it happen on factory presets? If it is happening only on presets you have customized it might be worth backing them up and then restoring them again. If that does not help rebuilding them from scratch might. Not a great solution but worth it if only a couple are causing the freezes.

Link to comment
Share on other sites

My freezes started with 2.00. With that fimware it would freeze after about 45 min of playing on its own. I went through line 6 support and they replaced the rack. same thing with the next unit. I found a patch it would instantly freeze on if I adjusted it through the editor. I ended sending the foot controller and rack back to line 6 for testing. They could not get it to fail and sent the equipment back, which failed shortly after I used it. After reinstalling the firmware I was able to use it without random freezing. It has continued to freeze with all the latest firmware versions. It will fail with either the editor or the rack itself adjusting some patches (factory patches) I rebuilt the computer and got the same result just to make sure it wasn't my computer. I did find out one thing, if I shut the foot controller off and adjust the patch it hasn't frozen. Since I don't use it other than my home I gave up on figuring on the problem. The expense of a new mobo, processor and memory on top of boxing and sending equipment back and forth just got to be to much. I have to believe its something between the foot controller and the rack together for me. 

Link to comment
Share on other sites

I see these posts periodically regarding Helix freezes. In the past they were usually related to specific problematic presets. This assumes the freezes are not related to the global reset not being executed after a firmware update or an Editor version that is mismatched to the firmware version.  Does this happen on multiple presets? Does it happen on factory presets? If it is happening only on presets you have customized it might be worth backing them up and then restoring them again. If that does not help rebuilding them from scratch might. Not a great solution but worth it if only a couple are causing the freezes.

 

In my case, I'm not sure it has anything to do with presets. Although the occurrence is rare, several times over the last couple of firmware versions, it has locked up during the boot process. The animated dna logo just stops. I don't know at what point Helix begins loading a preset, but when this happens, it's about 10 or so seconds in. Helix takes somewhere around 20 seconds to boot. I do have Helix connected to my computer always, which I suppose could make a difference. This kind of problem is nearly impossible to figure out, and it's rare enough that I just shrug and move on. If I was using Helix live, however, it could be a big problem, as I've also experienced a rare lockup while playing.

Link to comment
Share on other sites

 I have seen some freezes, but its almost always a patch that didn't get migrated properly. This may even be related to presets with Variax models and tunings. I have not seen freezes in an otherwise stable patch that was dependent on how long the Helix is on. That sounds heat related.

Link to comment
Share on other sites

In the past I have had freezes when connected USB to my Mac using the editor. I found that unplugging the usb cable would "unfreeze" it. I haven't had that issue since. 2.11, but that doesn't mean that it was fixed in a firmware update. Could be coincidence. 

Link to comment
Share on other sites

In my case, I'm not sure it has anything to do with presets. Although the occurrence is rare, several times over the last couple of firmware versions, it has locked up during the boot process. The animated dna logo just stops. I don't know at what point Helix begins loading a preset, but when this happens, it's about 10 or so seconds in. Helix takes somewhere around 20 seconds to boot. I do have Helix connected to my computer always, which I suppose could make a difference. This kind of problem is nearly impossible to figure out, and it's rare enough that I just shrug and move on. If I was using Helix live, however, it could be a big problem, as I've also experienced a rare lockup while playing.

This is the exact case that happens to me. I should have been more specific on how it freezes, but it freezes up on startup. It takes about 10 seconds or so for the Helix to boot up, but I have had three instances now since updating 2.12 where the Helix does not go to my presets, but the start up screen freezes. The problem is corrected by restarting the Helix, but I dont think I should have to do that. 

I updated my firmware by following the instructions for the update to a tee. 

I have the Helix pedalboard, not the rack

Link to comment
Share on other sites

Mine froze last night on 2.12, Mac OS X El Capitan, USB connected.

 

I just got a new Variax guitar.  I plugged in using the VDI cable, went to switch to a blank preset to try it out, and instead of switching to the new preset, it froze.  Reboot cleared it.

 

That's the first time 2.12 (or anything after 2.0) has frozen up on me.

Link to comment
Share on other sites

Fortunately, no Helix lock ups nor freezing encountered here yet.

 

It seems that the majority of posted reports here and generally on the various Internet Forums of the Helix locking up or freezing (other than when updating the firmware or reinstalling Presets), are when a computer and/or Variax are being used with it.

 

I specifically bought the Helix to be used without a computer, and I have not yet considered a Variax.

 

Sure do hope any instability issues are resolved soon, and do not begin occurring with my unit.

Link to comment
Share on other sites

I should be more specific about my freezing. 

 

My update was performed to a tee as directed on the Line 6 website. I used the supplied USB cable to connect my Helix to my computer. Followed all the directions as written and was maticulate about it. 

 

When my Helix re-booted, everything worked fine. A couple of days later, I turned my Helix on like I do any other time and the start-up screen froze. (As we know, the Helix takes about 20 seconds from the time you turn it on until the time your patch screen shows up). At the end of that 20 seconds, the screen was just froze, nothing was moving. I turned it off, went through the start-up process again and this time it started up fine.

 

This has happened 3 times since the update, intermittently. I turned it on, walked away and the screen was frozen. I have used it probably 20 or more times since the update. To me, that's 3 times more than it should have happened. 

Link to comment
Share on other sites

Another thing is I don't use a Variax guitar. My Helix is only connected by USB if I am using the editor or if I am doing an update. Otherwise its standalone. 

 

I do not have the rackmount version. 

 

I may try rebooting in a couple of weeks. I have all of my settings dialed in and (because of my goof) I lost all my presets last time and do not want to go through that again with a bunch of shows coming up. 

Link to comment
Share on other sites

  • 2 weeks later...

I get the same issue. There is a red error on the top left of the screen when I boot up. Something like -28 .i shut if off then restart and it's fine. Never had an issue while playing. Contacted support and they want me to ship the unit. I'm hesitant to do so cause it's more of an inconvenience than a performance issue. Anyone else have that red error message when booting up? Tried reinstalling and still same error.

Link to comment
Share on other sites

I have never experienced an issue with freezing when booting up. All my freezes are either immediate when switching to a corrupt patch (easily fixed), or intermittent while playing with a patch I very commonly use - but that has only happened once. I am using EXP 1 to control a volume block, and noticed the freeze occurred after turning down the volume pedal.

Link to comment
Share on other sites

I had my helix freezing up every time I would try to edit a block from an empty user preset. This has been since I bought it last July. It would only freeze trying to select what model I wanted to use from any category. I spent alot of time trouble shooting the unit, connections cables and so on. I just found the problem. I was using a Mission expression pedal that was designed for the helix.  If I unhooked the toe switch from the pedal it went away. I found the toe switch should have been a mono cable and I was using a TRS cable. Strange that it would work correctly when using it but would cause the blocks to freeze when programming. Now that i swapped out the cable I have zero freeze issues.

Link to comment
Share on other sites

I took a look at a HLX file for a guy who was upgrading and couldn't import it back without an error message.  I found what looked like some kind of divide by zero or other numerical conversion error repeated in the file's Variax string settings @min values.  Should the same issue occur within the memory of the Helix unit itself, I'm sure it would cause all manner of problems if not handled.

Link to comment
Share on other sites

My experience: my helix froze today for the first time since the 2.12 update earlier this week. The freeze was upon startup, but I was at a gig and nothing else was connected, no USB/computer connection. The Helix finally booted successfully after the third attempt. Also FWIW the patch I was using was freshly created after the update, and the update was done per all of the instructions including the global reset.

 

I have been so blown away with this awesome unit and it's the first modeling rig I've had that truly replaced a large analog pedalboard, but I have to admit I am a little concerned now. Hopefully there's something Line6 can find and address quickly.

  • Upvote 1
Link to comment
Share on other sites

I've had 3 freezes since updating and they always seem to happen when I have the USB plugged in, using Helix as a soundcard and have the editor open. It seems to do it when I'm changing things in my patches very rapidly on the editor. In my case it's probably a sync issue since it has to update on the pedal too. I'm probably just trying to transfer too much information at once for it to handle. Never had any freezes when I wasn't connected with the USB cable though.

Link to comment
Share on other sites

My 2.12 life has been much more stable than any other FW before. I really only use the editor to backup presets. I keep the USB disconnected since it is a source of error. I keep fine tuning my patches but in general I do less patch building than I used to (for the moment). We'll see if it stays stable when working on a new gig list.

Link to comment
Share on other sites

  • 4 weeks later...

This is the exact case that happens to me. I should have been more specific on how it freezes, but it freezes up on startup. It takes about 10 seconds or so for the Helix to boot up, but I have had three instances now since updating 2.12 where the Helix does not go to my presets, but the start up screen freezes. The problem is corrected by restarting the Helix, but I dont think I should have to do that. 

I updated my firmware by following the instructions for the update to a tee. 

I have the Helix pedalboard, not the rack

 

My problem exactly. The helix freezes when booting and a restart fixes it. Pedalboard version also. This odd behaviour started a few weeks ago. No clue what started the problem.

Link to comment
Share on other sites

Are y'all connected by USB to a computer when you boot?

If so, are you using PC or Mac?

What OS and version on the computer?

Is the editor active when the freeze occurs?

Do you have anything assigned to EXP 1 in the preset that is active when it is booting?

 

These questions need to be filled in with each instance of freeze report.

Link to comment
Share on other sites

  • 3 weeks later...

It just happened to me. I just updated to 2.12 last night, and I was reading some threads for another issue that I'm encountering while i rebooted and read this one and was like... that's crazy and wouldn't you know this very thing happened as I was rebooting for another issue!

 

This is concerning and problematic...

 

I am connected to the computer when I boot via USB. Windows 7, the editor was active, the vol pedal was asigned to exp2.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...