Jump to content
Sign in to follow this  
captainnemo70

Helix \ Variax issue

Recommended Posts

Hi Guys hope you can help with my issue.

 

 bit long winded this but bear with me.

when switching patches on the helix im having some issues with variax models.

 

example,

 

patch one has "custom" pos 4 as and acoustic

patch 2 has "custom" pos 5 les paul on bridge

 

now when i swap between those patches everything's fine , the variax switches across fine, 

 

now when i say go to patch 3 that has variax set to dont force, then whatever variax model had been switched to by the last patch, then thats the one that is used, which is fine,  however when i switch the pick up selector on the guitar, despite me being on a custom guitar on the variax, the model sound that comes out is whatever is at the position selected for the model that was previously selected model , instead of going to the model stored on the custom bank it goes to say another accoustic or if it was a les paul then another of the les models

 

so if ive gone to a patch with dont force on variax setting and i previously have had the acoustic model on, when i move the switch to my les paul position i dont get that sound, i get the model stored at pos 5 on the acoustic bank.

 

the only way to change it is to move the variax model selector off and back on to the custom bank.

 

i know that explantions very wordy, but it took me awhile to figure out exactly what was happening, 

 

hope that makes sense to someone, 

 

im pretty sure my pod HD pro didnt behave like that ?

 

simple setting error ?

 

Share this post


Link to post
Share on other sites

There are some well documented issue with variax/Helix. Line6 may not be aware of this one. Open a support ticket and post it in the bug thread

  • Upvote 1

Share this post


Link to post
Share on other sites

Hi Guys hope you can help with my issue.

 

 bit long winded this but bear with me.

when switching patches on the helix im having some issues with variax models.

 

example,

 

patch one has "custom" pos 4 as and acoustic

patch 2 has "custom" pos 5 les paul on bridge

 

now when i swap between those patches everything's fine , the variax switches across fine, 

 

now when i say go to patch 3 that has variax set to dont force, then whatever variax model had been switched to by the last patch, then thats the one that is used, which is fine,  however when i switch the pick up selector on the guitar, despite me being on a custom guitar on the variax, the model sound that comes out is whatever is at the position selected for the model that was previously selected model , instead of going to the model stored on the custom bank it goes to say another accoustic or if it was a les paul then another of the les models

 

so if ive gone to a patch with dont force on variax setting and i previously have had the acoustic model on, when i move the switch to my les paul position i dont get that sound, i get the model stored at pos 5 on the acoustic bank.

 

the only way to change it is to move the variax model selector off and back on to the custom bank.

 

i know that explantions very wordy, but it took me awhile to figure out exactly what was happening, 

 

hope that makes sense to someone, 

 

im pretty sure my pod HD pro didnt behave like that ?

 

simple setting error ?

 

That is normal behaviour - not a bug.

 

A change in this behaviour was implemented late in the POD HD series firmware and has carried over to Helix. This was done because most Variax players wanted it. They want to be able to use the pickup selector switch to select different positions in the Variax model bank model specified in the preset, ignoring the current physical model bank selector knob position. In other words, if you switch to a preset that specifies a T-Model for the Variax, that model bank is used for any changes to the pickup selector switch. Moving the pickup selector switch will NOT change the Variax model bank to wherever its knob is positioned - it remains in hte T-Model bank.

 

This setting remains in force until you manually or virtually (via a preset) change the model bank. So when you switch to a preset that says Don't Force, it does not force a change in the model bank. The model bank remains (to continue the above example) in the T-Model bank and a change in the pickup selector switch selects a different pickup position in the T-Model bank. This behaviour is exactly as you describe and is now normal behaviour.

 

If you want to change the Variax Model bank after switching to a 'Don't Force' preset you must do so manually. It the physical knob happens to already be in the model bank you want to select you must change to a new bank and then reselect the desired bank.

Share this post


Link to post
Share on other sites

Thanks for the explanation Silverhead.

 

i can see why people would want that, 

however it doesnt seem to respect the CUSTOM banks in the same way, i lose the flexibility of having a cpl of different guitars on the same 5 position switch

 

i suppose how ill have to cope with it is to copy the helix patches and name them for songs and add the variax model i want on that particular patch, which is a bit inconvenient to how id got used to using my HD for a cpl of years , i must have missed the last cpl of firmware updates on the HD maybe

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...