Jump to content
Sign in to follow this  
abaxe

On board expression pedal

Recommended Posts

 I'm noticing when I use the on board expression pedal that there is a squeaking noise when actuating the pedal. How can I fix this? Could I use Deox IT or some other cleaner or lube? Obviously I don't want to damage it. but the noise is annoying...

Share this post


Link to post
Share on other sites

After a year of use this just happened to me too. I read a lot of the suggestions made here by other users and while I'm no expert in the matter I just kind of used a combination of methods. Some people seemed to be more comfortable taking the pedal apart, but I could just see myself screwing that up when trying to place it. I ended up taking the back off and carefully spraying dry lube all around the lug nut that's connected to the controller. I just kept moving the pedal up and down to make sure the lube worked its way into the right spot. Luckily this worked for me. Sorry to be so long winded about something so simple.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...