Jump to content

POD HD Editor Not available for Download


Recommended Posts

Just noticed that the link to download POD HD Edit is broken.


After clicking through the license agreement, it goes to the following page:




But the page shows up as unavailable.  I've tried this with both Chrome and IE.





Link to comment
Share on other sites

I tried the latest 3 versions. I was trying for the Pod HD500 links, but also tried the Pod HD links and have the same problem.


Tried on 3 browsers on 2 computers which are on different networks (one at work, one at home).  After I click "agree" on the user liscence, it goes the screen indicating that it is downloading with the "if downloading doesn't begin, click here" message.  That screen pops up for ~1 sec then it goes right to the page I listed above with an error.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...