Jump to content

POD Farm just irredeemably broken in Windows 10

Recommended Posts

I'm almost ready to just buy some new (non-Line6) hardware for recording, because I've had my recordings on halt for at least a year trying to figure this out.


  • From a clean slate, I download the latest Windows 10 drivers for POD Farm, run the wizard, and choose the GX Drivers.
  • The drivers install successfully. I plug in the POD and the light turns green.
  • I check the Windows audio settings - no input measured by the POD.
  • I open the POD Farm application - no input. The GX is correctly recognized and selected, still no input.
  • I go into device manager to uninstall the drivers to try again. Attempting to uninstall the drivers will cause the dialog to hang requiring a force close. It never uninstalls the drivers.
  • I go to audio settings to switch back to my working audio input. The audio settings dialog hangs requiring a force close. 
  • Occasionally, audio settings won't even open, and even if I switch back to my not-bad sound card, it ceases to function as long as the POD is involved.
  • The POD is now completely unplugged and all audio is broken on my system.
  • If through some miracle of settings-tweaking I am able to get the input measured at all, the signal is INCREDIBLY distorted/corrupted (110% unusable)


And some answers to what I anticipate will be frequently asked questions...

  • The Line 6 License Manager is installed, both the PC and the device are authorized properly.
  • I am installing the hardware properly, I've done this countless times on Windows 7 and it always worked fine.
  • I have tried multiple USB ports.
  • I have tried multiple guitar cables.
  • I have tried multiple guitars.
  • I don't have another USB printer cable, but this one was purchased solely for the GX, it's only been used for the GX, and it's worked in the past.


Any ideas or am I just done trying?

  • Upvote 1
Link to comment
Share on other sites

  • 2 months later...
  • 2 weeks later...

This is an update to this topic in that I have a windows surface with win10 and after calling line 6 they claimed they are still having issues with the surfaces and getting pod farm to work, specifically the in and out. That being said, I did get it to work if I attach only the POD to the single USB 3 port without the hub. Bought 2 new hubs to fix this (had unpowered 2.0 before). This time I bought powered 3.0 and still no luck.


Line 6 needs to fix this, surfaces are popular laptops. All my software is over on it now. Going to my old workstation with windows 7 is no longer an option.


@Line6...Please give an ETA for when you might have new drivers for windows 10 to try. I can get get away with the mouse and keyboard since I can use the one attached but I need my drives. The pod farm should at least work through a powered hub like it did on win7


I also tried the hub with only pod tfarm going through and nothing

  • Upvote 1
Link to comment
Share on other sites

  • 4 years later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...