Jump to content

Recommended Posts

Question 1: I have an LR Baggs Dual Source pickup in a Breedlove and I'm trying to get rid of the high pitch frequency created through using the G10 wireless system.  It's a fairly common problem, but the solution seems hard to find.  Has anyone tried using a 6" TRS - TS adapter to successfully eliminate that buzz?  The recommended mono ts-ts adapter does not work.  Or how about a TRS to TRS male to female adapter?  Any other success stories to eliminate the high pitch buzz with the dual source pick up?

 

Question 2:  Does anyone use the G10 with the LR Baggs Anthem?  Do you get a high frequency buzz, and/or can you easily eliminate it with convenient to use adapters?

 

 

Share this post


Link to post
Share on other sites

Try opening a support ticket with Line 6 and they can help you directly with your issue. 

Share this post


Link to post
Share on other sites

HIGH FREQUENCY SOLUTION!  If anyone is still looking for a fix to the high frequency buzz when using active pick-ups with the G10, try a TRS male - TS female Adapter.  I've been battling the issue for a bit, and a ts-ts adapter is really the only simple suggestion, however, that does not address the signal issue.  A TRS-TS adapter (a 6" works perfectly...$7 at guitar centers) brings the active signal down to a passive signal and completely eliminates the high pitch.  I tried it yesterday with great success....sigh of relief.

 

As an add-on....with the 6" adapter the transmitter dangles.  A simple and easy solution for me was to put the G10 transmitter in an i-pod "pouch" usually attaches to arm bands (the smaller old kind of Ipod).  The 1/4 connections fits perfectly snug through the hole where earbuds wires would normally go, and the clip attaches perfectly to the guitar strap.

 
FYI: I use an LR Baggs Dual Source on a custom Breedlove

Share this post


Link to post
Share on other sites

Thanks for the info Ksav! That should help a lot of people out when searching for a solution. 

Share this post


Link to post
Share on other sites

What is your signal chain? I'm experiencing the hum as well but am running a few pedals between the G10 and the DI to the house. Curious where this adaptor should go?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...