Jump to content

Made a HUGE mistake...need advice.


Bela6
 Share

Recommended Posts

Hi There, this is my first post :)

 

I am trying to back up my Helix patches & install firmware updates....."gulp"... for the first time.

 

Got it Dec 2015 so I am running version 1.03 on the helix & I am unable to get it to connect with my computer.  I have tried downloading the compatible updater /software versions 1.03 and also tried 1.04. It just tells me that it can't connect or that I need version 1.4 or later.

 

From what I have read I need to back up with compatible software before updating. I realize I have made a HUGE mistake not keeping up with updating and I REALLY don't want to lose all of my presets.   I was so excited when I got it ...spent a ton of time making patches and then started using it at gigs and never looked back...lol!  I have just been a happy camper all this time!

 

UNTIL...Last weekend it went out on me when I engaged the EXP pedal from volume to wah in the middle of a gig.  I got no output sound but the patches are all there and tuner was working so input was fine.  Rebooting did not help. After rebooting the next day it works again though?!?   I then, of course, realized that I need to back-up & update ASAP.

 

I"m running on Mac os x El Capitan. 

 
Does anyone have any knowledge on what I should do first?  I really appreciate any help or advice!
 
 Thank you so much in advance!
Link to comment
Share on other sites

Back up first! That's key. Then you can risk blowing the update process. Although, you WILL lose all of your patches in the Helix in the updating process. You will also have to completely reset your Helix up Globally. You probably already thought of this but the only thing I can think of to do for now is try a different computer to backup your patches. Even a PC if that's all you can find.

Thoroughly read this.

 

http://line6.com/support/topic/18284-latest-helix-firmware-212%E2%80%94jan-9-2017/

Link to comment
Share on other sites

Yes.......as they say above - could well be cable or USB problem - change to a different USB port on your computer.

But, you are so far out of date, that you probably can't update to the latest version and keep your patches.  A lot of amps have been improved - so they will sound a little different.  Things like globals have changed - input impedance being one.  As it's now per patch, you probably will at least need to adjust that to get back to the sound you were used to. And there are a lot of amps you will probably want to use that weren't there at 1.03!  If you use a driven Marshall patch check out the newer Marshalls.  The Litigator can do killer clean to gentle smooth distortion - you might not be able to resist that if you like lower gain sounds.

So, backup - assuming you can get it to connect (I think v1.4 will still work to save your patches)  Save them individually by the way, then you can load them one at a time and trouble shoot any problems.

You can then just update to the latest version - 2.20 is out any day now......so if you can wait - it's meant to be a big one.

Expect a few long days getting it all working to a good level - you got to explore snapshots too - you most likely will convert all your patches to work with snapshots - most people do.......

Link to comment
Share on other sites

If you use IRs back them up and make sure you take a screenshot so you can restore them back to the same location. Backup your presets with a bundle, setlist, and individual preset backups to be thorough. If you are on the 1.03 firmware you want to do the backup with the matching 1.03 Editor. Do not use a different version. As others have indicated keep experimenting with different USB ports and different computers until one of those combinations sees your Helix properly. With the exception of some very rare occasions where the Helix or the USB cable is actually damaged some combination of the right computer and USB port will work. Hang in there! If you are using Windows make sure you let the "Helix" application install the driver as well as the Updater and Editor.

Link to comment
Share on other sites

Thank you all so much for the replies & advice!  The first step is to get my patches backed up & that is the hurdle I am dealing with now.  The comparable software version 1.03. is still available but it says it can't connect because I need 1.04 or later but my pedal is using 1.03 .  I'm going to try all your suggestions , different USB , different computer and read links you posted. Really appreciate all of your time & help in replying :)

Link to comment
Share on other sites

Was there an editor at 1.03?

How did you back up presets pre-editor?

Even before the "Editor" allowed you to change the blocks, routing, etc., there was an Editor-like app for the Helix that was a essentially only a librarian that could be used for backup and restores. I am assuming that Bela6 is seeing 1.03 as the firmware version coming up on the Helix when he starts it. " After reviewing the old notes in the firmware and Helix app for these early versions I am forced to revise my earlier comment though about matching the Editor version to the firmware version. It appears that not only are the firmware and Editor versions out of synch for the latest firmware release (they had been in synch for the last few versions), but it also appears that there were version mismatches early in the firmware release process as well.

If you use IRs back them up and make sure you take a screenshot so you can restore them back to the same location. Backup your presets with a bundle, setlist, and individual preset backups to be thorough. If you are on the 1.03 firmware you want to do the backup with the matching 1.03 Editor. Do not use a different version. As others have indicated keep experimenting with different USB ports and different computers until one of those combinations sees your Helix properly. With the exception of some very rare occasions where the Helix or the USB cable is actually damaged some combination of the right computer and USB port will work. Hang in there! If you are using Windows make sure you let the "Helix" application install the driver as well as the Updater and Editor.

Whoa, hold the phone (mumbling to myself). I just noticed the following quote from the 1.02 version of the "Helix" app - "- Supports backup and restore of new Helix delay models in 1.04.1". This implies to me that at some point in the past the firmware and Editor versions were out of synch with each other. It would also seem to imply that perhaps you need the 1.01 version of the "Helix" app to backup 1.03 firmware version presets. Not enough notes regarding version matching to be sure though. At this point I would recommend contacting L6 support to confirm which version of the Editor to use to make your backups from the 1.03 firmware. I agree with jbuhajla that you may want to wait until the 2.20 firmware to do the firmware upgrade but it is never too early to get everything backed up so I would get that version issue straightened out now with Line6 so you can get some backups and are not left sitting on the fence when the new upgrade hits.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...