Please ensure Javascript is enabled for purposes of website accessibility Jump to content

Variax JTV-69 magnetic pickups inop since unsuccessful attempt to use Workbench

Recommended Posts

I bought a demo Variax Standard from Sweetwater Sound about a month ago and have been impressed with guitar, so I recently purchased a used JTV-69, estimated year 2012. The previous owner claims never to have used the interface hardware/software  that came with the guitar.

I installed the Workbench software and Line 6 Monkey onto my Mac which is running on OS 10.6.4. The Workbench hardware/software combo claims not to recognize the USB connection; it keeps telling me to plug into a USB port on the computer when it's hooked up. When I look at the interface box, I see a green light and a flashing red light, so at least I know it's getting power from the computer. 


I worked on this situation for some time with no success. I finally decided that the guitar probably had to be hooked up to the interface, so I tried that. Still no success. I ran out of time to deal with it, so I disconnected everything and put it away for a few days. 

When I got the guitar out and tried to use it, to my surprise the magnetic pickups were dead! No sound what so ever from the amp. I swapped guitars with the same cable into the same jack of the amp and that worked, so I reconnected the JTV. Still no sound. I switched to the modeling sounds through the 1/4" cable and they worked fine; just no magnetic pickups.


Could the attempt to get the Workbench software working have somehow switched off the magnetic pickup output? 

Am I missing something here? 


Any ideas/suggestions would be extremely welcome at this point. I am seriously worried about attempting anything with my Standard until I know what's going on with my JTV.



Link to comment
Share on other sites

When I look at the interface box, I see a green light and a flashing red light, so at least I know it's getting power from the computer.

If either of the lights on the USB dongle are red, then you have a connection problem. Is it on the computer side or the Variax side? When connecting everything, you need to have a fully charged battery, AND a 1/4" cable plugged in. This "turns on" the guitar, and is probably the reason the computer is not recognizing anything. Those dongles are a crap shoot, and can be very finicky.


The mag pickup issue is more of a mystery. Even with no battery installed, they should still function just like any other guitar.

Link to comment
Share on other sites

Thanks for the info. The Workbench Pilots Guide is vague about hookup connections. 

So regarding the magnetic pickups: the Workbench application has no way to switch them off? I presumed that they might be run through the software somehow. 

I guess it could be a 1/4" jack issue, but the guitar wasn't used much at all, and hasn't exhibited any issues until after the attempt to use Workbench. 

The next thing to check is continuity through the jack?

Link to comment
Share on other sites

Mag pickups should function just like any other guitar with the 1/4" cable, with or without the battery installed. Workbench can't "turn them off", as it were. But even if it could, you weren't able to connect to it anyway, so it is somewhat of a mystery.


Once you do manage to connect to the computer, I'd start with re-flashing the firmware...for whatever reason that seems to remedy some of the weird issues that these guitars tend to have. Plus, if the previous owner claims to have never connected to a computer at all, then it's likely that you're running an older version of the firmware, perhaps much older than the current one.

Link to comment
Share on other sites

Here's what I've found re: workbench application: 

1. The guitar has to be registered, even if it was bought used and you have no idea about the purchase date. Just enter when YOU bought it, and it'll work.


2. ALL connections have to be made: battery in the guitar, 1/4" cable plugged it, interface cable plugged it. 


3. Latest Line 6 Monkey update done. 


Then it all began working! The unrecognized USB was apparently attempting to hook up an unregistered guitar.


The magnetics still don't work. Everything past the output jack of the guitar checks out, so the I'm removing the jack plate so I can access the connections on the jack itself. I'll report back what I find.


Thanks again for the tip on Workbench.

Link to comment
Share on other sites

BTW Guru, Thanks for recommending the reflash of the firmware. It does sound better on several of the models, especially the acoustics. That's what I was after when I started all this! As soon as I get the mags sorted out, I'm going to work on getting the acoustic models improved per some recommendations I've found here. 

Link to comment
Share on other sites

OK; here's the update: I tried the guitar one more time. Still no mags. I removed the output jack plate and checked the jack continuity the best I could without undoing any wiring. No problem found. While the jack plate was loose, I plugged the guitar direct into my test amp, and I got sound from the pickups! I unplugged and replugged several times, and it worked every time. i unplugged it again and reinstalled the plate. Plugged it in, and it still worked. 

Problem solved...I thought. I turned on the modeling and switched to several different models, intermittently switching to the magnetic pickups. They continued to work several times, but then went dead again when switching from modeling to mags. So far, I haven't been able to get them back, and the guitar is currently sitting with the jack plate hanging loose and the cover off the motherboard cavity. 


Looking at the installation, I see wiring harness coming from the motherboard to the output jack printed circuit board. From what I can see, the wires from the pickguard area all run directly to the motherboard. There are two sets, which are identical and go into a single connector. I presume these are the wires from the 5 way switch; one set is for the magnetic pickups, and the other must be for the modeling selections. The coloring is red, white, yellow and black, 

Farther down the board, 4 wires --red, white, yellow and black--go to the output jack PCB. Wiggling the wires produces no sound, and neither does unplugging and reconnecting the connectors those wires go to. I've sprayed all the connectors I've removed with contact cleaner. 


Bottom line: I'm stumped. The modeling works fine, the mags work very intermittently, and since last dying haven't come back, even with all my poking and prodding. The one thing that's consistent every time the mags stop working has been switch the modeling on and off. Is there a connection through the modeling selector push switch??  

It's apparent that the signal from the mags runs through the motherboard, even if there's no processing. There is no other possible connection based on what I see in the motherboard cavity. I really hate the idea of pulling the motherboard to trace the signal! 


Is there any kind of wiring diagram available for this guitar; at least one that covers the magnetic pickup circuit path? I'm thinking of establishing a "true bypass" circuit path with a switch that I can use to cut in/out the magnetics w/o going through the circuit board. 


Any thoughts?

Link to comment
Share on other sites

Mag pickups themselves are almost indestructible. They either work, or they don't. This is some kind of intermittent switching problem related to the model knob. It's service ticket time. The more complicated the plumbing, the easier it is to clog the drain...

Link to comment
Share on other sites

Yes, there is a relay. I hear it click when I switch in and out of modeling. The solenoid part of the relay works, but there may be an intermittent contact issue I guess.


At this point I guess I need to open a service ticket.


Thanks for all the help and suggestions!

Link to comment
Share on other sites

Does anyone know which terminal is the "hot" out from the mags on the 5-way switch circuit board? I want check the pickup signal from the switch thru the harness to the board to be sure I'm not loosing it before it gets there.

Link to comment
Share on other sites

  • 3 weeks later...

I got the magnets working again, and they've stayed working for a couple of weeks. Not sure what the issue was, but one thing I did was short out the capacitor on the output jack plate circuit board. When I put everything back together, the pickups worked.

Wish I had more definite info to report.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...