Jump to content

Loss of dynamics...?


FarleyUK
 Share

Recommended Posts

Played a gig last night, and there was something 'off' about the Helix. No idea how best to explain it, but the 'feel' of it just didn't seem right.

 

Recently upgraded to 2.20, and this was the first gig since. Maybe it's my imagination.... Just really felt that the feel of the Helix wasn't dynamic, and the sustain was not right.

 

Maybe I just need more practice, but it was fine at the previous gig..!

 

A bit more detail - I remember thinking the overdriven sounds didn't seem as rich or powerful ad usual; I even tried three different amps in each set, and felt the same in each (Plexi, JCM800 and Line 6 modded JCM800).

 

Going via dual xlr out to 2 alto TS210's.

Link to comment
Share on other sites

So many variables affect sound. How loud the rest of the band is, the room, the number of people in the room, your mood, dead strings etc. all affect tone.

 

The last gig I played the same sounds that had been coming from my monitor for months sounded thin and weak. It was distracting. But when I walked in front of the mains in the middle of the bar it sounded fantastic, so after that I stopped worrying about it.

 

Not to say there may not be something going on with your set-up. Just pointing out that it could be any number of different things.

Link to comment
Share on other sites

Played a gig last night, and there was something 'off' about the Helix. No idea how best to explain it, but the 'feel' of it just didn't seem right.

 

Recently upgraded to 2.20, and this was the first gig since. Maybe it's my imagination.... Just really felt that the feel of the Helix wasn't dynamic, and the sustain was not right.

 

Maybe I just need more practice, but it was fine at the previous gig..!

 

A bit more detail - I remember thinking the overdriven sounds didn't seem as rich or powerful ad usual; I even tried three different amps in each set, and felt the same in each (Plexi, JCM800 and Line 6 modded JCM800).

 

Going via dual xlr out to 2 alto TS210's.

 

Could one of your output settings be set to Line instead of Mic since you did your global reset? Just spitballing here as it sounds like you lost "feel" and you report the overdriven tones not sounding as "rich or powerful". Both of these symptoms might be attributed to a lower signal level at the outputs.

Link to comment
Share on other sites

I've had this happen to me a couple of times.  Each time I later found out it had to do with mistakes I'd made when setting things up, not with the Helix.  In one case I had come out of the L/Mono 1/4" on the Helix but had plugged into the R input on the DXR12 rather than the L/Mono input.  Another case the volume level on the DXR12 had gotten turned down.  Sometimes it's just simple goofups in setting things up.

 

However, since you just upgraded and reset your globals, I'd say to go and review all your global settings and make sure there isn't something there that you may have forgotten to change.  If everything sounded good to you after the upgrade when you were practicing, it's probably not something in the Helix.

Link to comment
Share on other sites

Shouldn't it be set to line?

 

Good point. Not sure if you were referring to the comment about mic versus line level but just in case...I don't own them but I think the Altos accept either line or mic level and you simply set the input volume knob level appropriately. I was referring to the fact that if you have whatever you are monitoring the Helix with set up for mic level output from the Helix and you do a global reset and that output ends up, unbeknownst to you, set to line, it can impact your sound.

Link to comment
Share on other sites

One thing I did recently was plug my guitar into the "Aux In" jack, instead of the "Guitar In'.  It sounded exactly like what you're describing.  Like it was running on flat tires.  I knew it sounded better the last time I played,  Must be my patches, right?  Nope.  Wrong jack.  Doh.  I think I might put some tape of that jack, since I don't use it.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...