Jump to content
Sign in to follow this  
MacShock

Helix direct into m20d mixer

Recommended Posts

Hi, I tried to connect my helix via xlr direct into the m20d (also tried into L3t and from L3t out into the m20d).

There was quite a bit of clipping going on even though the meter was not showing any clipping. I wanted to to trim (using the auto trim option in m20d) but the mixer could not adjust saying "signal too hot". It is a bit weird since I did not have the impression I played very loud. In the helix I did just update to firmware 2.2 and all global settings are on "default". The xlr out is set to line level. The big volume know was set to the middle position. Very strange. Anybody has experience with that?

Tks

 

Markus

Share this post


Link to post
Share on other sites

Set the helix XLR Outputs to mic level. Start with the M20d trim at its lowest level and increase manually if necessary.

 

Also it's important to balance your presets on helix to avoid having to adjust the M20d trim constantly.

Share this post


Link to post
Share on other sites

Make sure, you have switched of +48 power in the input row where you plugged in the xlr from Helix. Does not work together properly. ..

Share this post


Link to post
Share on other sites

You might want to consider saving channel 1-12 for mics and instruments that need the bigger processing chains. If you run your Helix into a pair of channels between 13-16, those are line inputs that have lighter weight processing chains that work great for line input instruments. All depends on how many channels your a using on the md20. My uses an md20 to record rehearsals. 8 channels of drums (mics), bass and 3 vocals are in 1-12. My guitar is 13-14 and keys in 15-16...just a thought...if you did that and needed the XLR outs, you can just adapt to TRS...

 

If you wanted to leave your Helix at Line level and use a 1-12 channel, then just adapt to TRS...I actually run our kick and snare mics (D112 and beta 57) into TRS in channel 1 and 2 adpated to TRS because the md20 input will not trim down quite enough. I am not a fan of the auto trim feature.

Share this post


Link to post
Share on other sites

I have not used my M20d in quite a while but I also remember having problems trimming channels low enough in certain scenarios. That mixer does not seem to have a very dramatic cut when the faders are cranked all the way down. The M20d probably could have used a bit more latitude on the low end of the fader(knob) or an additional available db cut setting. I think you will just have to find spots in the Helix signal chain to attenuate the level going to the M20d. Another option might be to use a DI that has a db cut switch. That way you could keep the signal coming out of the Helix nice and hot but reduce it before it hits the M20d.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...