Jump to content
Sign in to follow this  
beauviarts

POD HD500 Bottom Row Switches Disabled

Recommended Posts

Hello,

 

So I acquired an HD500 through a trade. It has been a little work as I discovered I was given the wrong power supply for the unit and it would overheat and restart mid-gig. I purchased the correct one and everything has been great. 

 

Every once in a while my FS3 freezes up but seems to work after a few minutes. Sometimes it works immediately. I took the pedal apart and blew some dust out and it hasn't really given me any issues. All has been well EXCEPT today=(

 

I booted up my HD500 and the entire bottom row of footswitches were not working at all. I immediately thought that it sounded like a software issue or the ribbon connecting the bottom portion was disconnected or something. So, I took it apart again and everything seemed fine. The strange thing? I reassembled the board and googled for about 10 additional minutes. I plugged it back in and the switches work perfectly. The firmware is up to date and I just want to know: 

 

Has anyone else experienced this? If so, what the hell is happening?

 

How can I rectify this and avoid this issue in the future?

 

I appreciate any comments ahead of time.

 

Thanks guys,

 

Beau 

Share this post


Link to post
Share on other sites

All I can attest to is that some strange glitches, bugs and hardware issues can happen with it. Anything from sudden volume issues to footswitches not responding properly and other things but overall my HD500 still seems to work for the most part and I still have the original power supply. On the other hand I don't gig with it so it doesn't get roughed up, subject to other power sources or exposed to the weather. It does however have many hours on it and has never been taken apart. I can say the same thing about my X3 Pro.

  • Upvote 1

Share this post


Link to post
Share on other sites

I think you guys are hitting the nail on the head! Maybe that's why they released 500x shortly(ish) after. In any regards, thank you both!

Share this post


Link to post
Share on other sites

I wouldn't poo poo the switch assemblies too badly based on a used unit you picked up in a trade. The tactile switches that are used are in many things and are fairly reliable (same ones are used in the old GNX series IIRC). Anywho replacement upper and lower switch assemblies are pretty cheap if that is the problem (and you don't want to solder) and DeOxit can breath some life into them assuming its an actual switch issue.

 

Sometimes it is the ribbon cable itself that goes bad, oxidized connector pins or there may be a cold solder joint.

 

The 500x (IIRC) was released due to parts availability for the 500 getting slim.

  • Upvote 1

Share this post


Link to post
Share on other sites

I agree with BillBee. Buying a computer used is always a risk.

Who knows how much rough treatment it got.

Hopefully something can be done about it.

 

Always first is the power supply itself. Strange errors mostly on booting up has come up too many times. But you 

have handled that. If the old PSU was over spec'd that could be the issue if under spec'd less likely.

Ribbon cables are glued at the clipped join. Unlikely but who knows what sort of environment it has been in.

If you or someone else has opened it up before remember that most problems are caused by the user when they first 

get a unit. What changed?

Buy a can of compressed air and get under those switches with it and or deoxit.

Next would be to go to the most suspect switch and replace it. 

  • Upvote 1

Share this post


Link to post
Share on other sites

Got site access probs as I tried to edit previous post.

It looks like you might of solved it and will never get a prob again!

  • Upvote 1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...