Jump to content
Sign in to follow this  
Soultrainer

Did I broke something?

Recommended Posts

I use XLR cables to monitors. I tried to change them to TRS cables but I could not hear anything. Now I cant hear anything with the XLR cables either. Power was always on in Helix and in monitor. I still can hear guitar trough headphones and I can hear PC voices trough Helix and monitors but I just cant get any guitar sound from monitors via XLR cables.

 

Could I have broke something?

 

 

Share this post


Link to post
Share on other sites

Hi, if there would be anything broken, i suppose you would'nt hear anything via xlr.

So probably there's something changed in the input/output configuration/routing.

Share this post


Link to post
Share on other sites

cycle power on Helix and monitors and see if it comes back. Also, check fuses in monitors if they have fuses. 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...