Jump to content
Sign in to follow this  
IgorCrous

Pod X3 Pro + Gearbox Issues

Recommended Posts

When I want to edit some of my patches on Gearbox I get this message:

"This tone requires you update your POD X3 to 2.00 or higher"

According to Line6 Monkey everything is up to date (green check mark next to each item).

I've got Gearbox 3.72.0
Line6 Monkey 1.64

   - Drivers 7.2.9

   - USB Firmware 1.00

   - Flash Memory 2.10

Can someone please assist?

 

I'm using OSX 10.8.5 on a 2010 Macbook Pro

 

  • Upvote 1

Share this post


Link to post
Share on other sites

I have the same problem. I am sure that Line 6 has not introduced a problem getting to sell new models. Are not line6 products an investment for the future? I will not buy Line6 products if it means they will start to malfunction when new models come out.

Share this post


Link to post
Share on other sites

I think it has to do with the user presets being created before a flash memory update. I had the same issue on my X3 Pro. It also made the X3 restart when I accidentally hit preset 32A on the FBV as I found out during a gig (yikes). Looking into it more at home the restarts happened when selecting ppreses over 8 which in Gearbox all gave the message to upgrade to 2.0. I fixed by reflashing. Fist to fhe latest version which didn't work. Then to the oldest version which did work then back to the latest. Select to not keep your old sounds during the process. Save your old sounds before the reflash process and after you are done load the bundle you saved and select only the presets you need and send to the X3. Worked cor me. Hope this helps.

Share this post


Link to post
Share on other sites

Greetings - also having issues w/ my X3 Pro and GearBox.   I hadn't connected to my Mac for a couple of months perhaps so not entirely certain what's the culprit but here's the info:

 

MacBook Pro, OSX Mavericks 10.9.1

Monkey says i'm on 7.3.6 drivers (all latest as of today)

 - Device firmware 2.10

Line6 License manager - v1.07

 - it sees my X3 and reports the S/N and says 'YES' to 'authorized'

 - also confirms that my MacBook is authorized

GearBox is 3.72

 - when i start GB it says it's "ignoring connection to POD X3 Pro. This device has an incompatible driver installed"

 

Has something changed in Line6 land where GB is no longer the right software?

I see Pod Farm2 is now installed but i don't have a license for it. Is that what we should use now?

 

TKS

Share this post


Link to post
Share on other sites

Gearbox is still the correct and only editor available for the x3 series.

Share this post


Link to post
Share on other sites

tks...but that's a bit discouraging for a product that's really not too old for Line6 to sunset it's software and not provide a forward path.

Share this post


Link to post
Share on other sites

they had previously announced that support for the X3 would end January 1st 2014. the x3 is quite a few years old. (and the software has not been updated for quite a few years and probably never will be)

they cannot predict what changes windows or mac will mac to their systems... mavericks changed something that seemingly doesn't want to work with the older software.

mavericks is what changed... not line6.

i'm confident it can be made to work... with the mac being a closed OS, things are not as easy to tinker with as they are on windows...

 

you might try removing the current driver and reinstalling some older ones as an idea...

but its all guess work... as i do not know the answer to your issue.

Share this post


Link to post
Share on other sites

So I am having the same exact problem as avanveld, can you instruct me on how to reinstall an old driver (which would be the latest before all these changes). This is very frustrating because I have grown accustom to my x3 pro and have purchased every additional thing I can on it and use it in my recording studio and now have no easy way to tweak it per customer without using the unit front. 

Share this post


Link to post
Share on other sites

this worked for another forum user... 

 

To remove driver 7.3.6

1- On a terminal run this command   sudo pkgutil --forget com.line6.driver.xtaudio.package (enter)

2- Then this sudo pkgutil --forget com.line6.driver.xtmidi.package (enter)

3- Reboot

To install driver 7.2.9

4- Downloaded driver version 7.2.9  http://line6.com/sof...a.html?rid=5675

5- Run the 7.2.9 driver package to install it and ended the process with a reboot

Share this post


Link to post
Share on other sites

this worked for another forum user... 

 

To remove driver 7.3.6

1- On a terminal run this command   sudo pkgutil --forget com.line6.driver.xtaudio.package (enter)

2- Then this sudo pkgutil --forget com.line6.driver.xtmidi.package (enter)

3- Reboot

To install driver 7.2.9

4- Downloaded driver version 7.2.9  http://line6.com/sof...a.html?rid=5675

5- Run the 7.2.9 driver package to install it and ended the process with a reboot

 

Just had a hard drive disaster, after downloading all the new software Gearbox woiuldn't communicate with the X3 Pro

 

This worked brilliantly, so thanks for posting.

 

Using Mavericks 10.9.5

 

Cheers!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×