Jump to content

pod Hd400 and Digitech Trio+


ginster
 Share

Recommended Posts

I had a Zoom G1Xon connected to the Trio+ with no problems.

Since I received a pod hd400 yesterday I tried to connect it the same way.
I noticed some sort of distortions or overdriving effects.
I cabled as follows:
                                Guitar>Trio guitarinput.
                                Trio FXsend >Input guitar pod
                                Trio FXreturn>output pod
                                 Trio Mixer out>Mixer>PowerAmp
Thanks for help.

Link to comment
Share on other sites

you might need to set the output level on your trio FX send to instrument level...Also, make sure the POD output level is set accordingly,,,If it needs to be instrument, set the level to AMP....otherwise use LINE if you need line level.

Link to comment
Share on other sites

.. and put input 1 to Guitar and input 2 to an unused device on the POD (like Variax or Aux in each patch (or global)).

I'm afraid but the HD400 only has 1 input.

Link to comment
Share on other sites

Actually the Trio is devil's evil. Not okay to be replacing the bass n drums. You will soon tire of it! LOL Seriously destroy them all!

 

For routing the Trio would be best inserted into the FX return and back in via the normal HD output!

Link to comment
Share on other sites

I just have the regular Trio but I use an A/B switch prior to so I can route the signal direct to the HD after getting the Trio going. For monitoring the HD goes to an amp and the Trio to either a separate amp or PA. Sometimes I will route both to a mixer then to the PA.

Link to comment
Share on other sites

Actually the Trio is devil's evil. Not okay to be replacing the bass n drums. You will soon tire of it! LOL Seriously destroy them all!

 

For routing the Trio would be best inserted into the FX return and back in via the normal HD output!

I'm a lonely child. There is nobody to play with. It's a drag. So Trio+ is my mate!

Link to comment
Share on other sites

I'm a lonely child. There is nobody to play with. It's a drag. So Trio+ is my mate!

 

The TP+ is pretty cool with the "tamed" bass player. Prior to the firmware update,  the Regular Trio was a free formed jazz oddessy.

Link to comment
Share on other sites

It is an amazing bit of kit. Reminds me of the auto accompaniment on a keyboard. You do get sick of it eventually, but I got to say

the simple bass makes it much more guitarist centric!

Be interesting to see where they take it from here.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...