Jump to content
Sign in to follow this  
brandonvu1997

M9's Footswitch Activated By Itself

Recommended Posts

My M9's record footswitch seems to have a habit of turning itself on. Whether I'm activating another pedal or turning on a separate preset, it would just start recording a new loop or turn on the reverb I have set to it. It's quite annoying and I can't use it anymore. I've tried looking at the footswitches inside, and one of the springs was a little weird. I switch the little screws that pushes and activates the switch for the record and stop switches, and the problem was moved to the stop switch. I decided to temporarily switch the bad screw/spring to the tap tempo so I can still use it as a looper, but the problem came back to the record after 10 minutes of playing! I also found that the footswitch itself doesn't click like the others do when you press it. Anyone have any ideas?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...