Jump to content

Snapshot problem


kenmac1
 Share

Recommended Posts

G'day groovers,

I am using the Helix and a couple of JTV guitars direct to a Desk / PA.

What I am hoping to achieve is a way to get between sounds without the dreaded silent gap, ie using snapshots, but what I need is something i am not sure can be done using this gear.  The shop seemed to believe these things can be done, but I think either I have the HELIX beat, or it has be beat.  Either way it is not playing the game.

I want to be able to jump between a clean "Acoustic" (JTV) sound, "12 Sting Acoustic" (JTV), a Combination / split of Acoustic and magnetic pickups with the pickup running through a crunch drive amp sim, A nice usable clean electric sound maybe with a little chorus and reverb, Crunch rhythm sound with light reverb, Crunch rhythm with Flanging, A standard smooth fairly high gain, volume boosted lead sound with the same delay as used on the acoustic patches, and lastly the same sound with a split harmony a fifth above.

Whether these are achieved by using stereo patches or not I do not care, as long as I can switch from acoustic, to 12 string, to Les Paul or Tele, or Strat... with the various fx and / or amps I have set within the snapshot banks.

So that will use the eight snapshots in one bank.

Now my problem is that I can't seem to switch between JTV sounds with the footswitch inside of snapshot.  If I set one snapshot to be an acoustic sound, so I switch out most of the fx and the amp sims, and just use a little eq, and delay with the JTV set to acoustic one, all well and good, but when I set up the next snapshot to be identical but with a 12 string, it changes the input sound of every patch, same goes for if I set up a Les Paul tone or similar, all my acoustic, 12 string,  and everything else revert to that electric guitar inside the JTV. / HELIX rig.
Is there a way to create all these sorts of sounds in the single batch of snapshots. 

My music requires me to switch back and forth from acoustic to electric, or combinations in some cases several times per song, as well as jumping to higher gain, chorused, flanged and other fx like wah all night long, and the silent gap between changeovers is frustrating.  In fact the whole reason I went to the Helix was because I expected the Snapshot feature to be able to do these changeovers without losing sound each time I press a button, otherwise I would never have switched from the HD500X.  Could have saved myself $2700 AU by staying where i was.

To try and be more specific.  When I switch between six and 12 string acoustic, the rest of the patch is identical, so the same eq with the same settings, same gentle delay and compression is used in both "Acoustic" based patches. 
When I want the split sound so an acoustic tone on one side and a magnetic pickup on the other with amp sims...  That seems ok, but as soon as I set the next patch to have a 12 string instead of a six string acoustic, every patch adopts that JTV setting, so if I then set up the next patch wanting the JTV to now be a Les Paul, or a Tele.... with an amp sim, so I switch out the eq, and compression I was using in the acoustic sound, and switch the amp, distortion flanging... back in, but every variax sound becomes that Les Paul or tele... across all eight snapshots, so I lose the acoustic sounds.

Link to comment
Share on other sites

I have no idea what any of that means Meister.  I may have been using the HD for a few years, but i am still a simple pedal user at heart, and as much as people say the HELIX is meant to be easier to use than the HD, I beg to differ.  This thing is screwing with my head, three months down the track.  In fact I usually just give up and go back to using amps and stomp boxes with old fashioned strats, teles and other guitars in my harem for gigs, rather than tear what few remaining strands of hair I still desperately cling to from their defective follicles. 
I guess question one, can each individual bank within the Snapshot set be assigned a different input sound from the JTV, ie acoustic, 12 string, Les Paul, Tele... or does a group of snapshots in the same bank need ot be assigned the same input sound across the board?
If so where is the information on that process please?  The manual I printed off does not even seem to go into snapshots looking at the index, so I scoured a few dozen videos on youtube to just to learn how to activate snapshots.   These guys seem to know what they are doing, but the camera work and descriptions leave a lot to be desired for the technically challenged among us (That would be me and my ilk)

I'm now gonna go and see if i can see this global change thingamy, although I have no idea where to even look.

Link to comment
Share on other sites

In the preset you are working with select the Input block. Set the Input to Multi or Variax. Set the Variax parameter to Per Preset (not Global). Although this parameter is associated with the Input block of each preset it is in fact a global parameter. This allows you to change the Variax model to a different setting for each preset.

 

Now, within the preset, assign the Variax Model parameter to the Snapshot controller. You do this by simultaneously pushing and rotating the Variax Model parameter knob on Helix. You will see brackets appear around the Variax Model setting. For each Snapshot, set the Variax model as desired and SAVE the preset (hence the Snapshot's Variax Model setting) before you leave the snapshot to use a different Variax Model on the next Snapshot.

 

Also, make sure you are using the most recent manual. You will find it in the Support - Technical Support - Manuals section of this website. It describes the use of Snapshots.

Link to comment
Share on other sites

As twpmeister said, go into the input block, where I assume you are going to change the Variax input selection for each snapshot, and change the Variax control setting from global to per preset. 

That should be the easiest part of your problem. 

Link to comment
Share on other sites

Thanks guys.  This makes some sense.  Still wish it were as easy as setting a distortion pedal....  but hey this is the computer age. 

I did find a later manual last night, and it has a whole added section on snapshots that is not in version 1.0 that I had been using.  Hence I was seeing all these guys doing snapshot stuff, and my manual that had been printed off had no reference to them at all, so I was totally shot.

Link to comment
Share on other sites

It is definitely set to per preset, and still refusing to play the game. 

I'm sure the Helix gear hates me.

I even connected it to my macbook, so I could get a better look at the setting on the big screen.  When I look down the input screen on the Mac interface, I have it set as Multi, then selected Variax, acoustic 1 (for example) under variax settings is says per preset, not global, but as soon as I jump to the next screen after saving that patch as I want it, and select 12 string, the first patch also reverts to 12 string.  

Another thing it is not letting me do is name each individual patch within the snapshot set as per what they are meant to be set as,  ie Acoustic, 12 String, Tele Clean... 

This is really doing my freaking head in.  What else could be causing this, or may need to be altered please?

Link to comment
Share on other sites

I can't see any way to attach a screenshot of my computer to the forum, that way you guys can see exactly what I am seeing, and might be easier to identify where this thing is screwing me up.

Is there a way to attach photos?

Link to comment
Share on other sites

In the same place as you select per preset you then get 'preset variax model' this is what sets your variax for the preset. If you press the corresponding encoder knob brackets come either side of your selection - you can then select different ones for different snapshots within that preset. I'm doing it right now- spank 5 into hiwatt switching to lester 1 into plexi within the same preset with the snapshots.

Link to comment
Share on other sites

I think where you're going wrong is that you are not pressing the knobs to select different guitars for the snapshots. If there are no brackets you are selecting for the whole preset. With brackets (by pressing the knob) you are selecting for the individual snapshot

Link to comment
Share on other sites

I managed to work out how to change individual patch names last night before you replied, because I saw another post where several guys had the same problem and somebody told them how to do it on a computer screen, so I did it that way.   But thanks.

As for the brackets, as I select each instrument (Acoustic 1, Acoustic 2, Lester...)  they definitely have brackets around them, and that seems to be how it sets as default.
I just rang the store I got it from, but nobody there really knows anything about this gear, since they are old school players, guitar, stomp boxes, valve amp...  So they are now calling the Australian rep for the company to see if he can work out why this is not working.  

I have been selecting the sounds by having the JTV plugged, in, and when I want patch 1 for example to be a Strat, I dial that in on the JTV, and it automatically corresponds on the screen of both the Macbook and the Helix, and the brackets seem to be automatic.    However when I save it and move to the next bank, that has also adopted the same input. 

Link to comment
Share on other sites

I managed to work out how to change individual patch names last night before you replied, because I saw another post where several guys had the same problem and somebody told them how to do it on a computer screen, so I did it that way. But thanks.

As for the brackets, as I select each instrument (Acoustic 1, Acoustic 2, Lester...) they definitely have brackets around them, and that seems to be how it sets as default.

I just rang the store I got it from, but nobody there really knows anything about this gear, since they are old school players, guitar, stomp boxes, valve amp... So they are now calling the Australian rep for the company to see if he can work out why this is not working.

I have been selecting the sounds by having the JTV plugged, in, and when I want patch 1 for example to be a Strat, I dial that in on the JTV, and it automatically corresponds on the screen of both the Macbook and the Helix, and the brackets seem to be automatic. However when I save it and move to the next bank, that has also adopted the same input.

You need to see [square brackets] like the one around the text "square brackets" to ensure that your parameter, in this case the "Variax Model" is assigned to snapshots. Square brackets, not parentheses. Snapshot assignation is not automatic with the Variax model selection and neither are the square brackets, you have to explicitly assign the parameter. As others have mentioned make sure you have the parameter on the Input block, "Variax Settings" = "Per Preset" selected.

 

You may want to try the Editor method below. Make sure you mouse-click per the instructions below on the Variax model parameter while you are using one of the methods below - Windows or Mac. You can also assign the parameter directly on the Helix by quickly pressing and turning the "Variax Model" parameter. If you have done it correctly square brackets will appear around the Variax Model.

Courtesy of Phil_m and the release notes

- Snapshot Assign Shortcut—OPTION-click (Mac) or ALT-click (PC) any Home screen parameter to quickly assign its value to the Snapshots controller

 

- Unassign Controller Shortcut—SHIFT-OPTION-click (Mac) or SHIFT-ALT-click (PC) any Home screen parameter to instantly remove any controller assignment

Link to comment
Share on other sites

It started working.  Not sure how or why, it just suddenly did what I wanted it to do, after freezing up a few times and being turned off, on, (almost thrown at the wall by that stage).
So I got the patches I wanted sorted.  May still fine tune them later when my ears have had a few hours to recover from the marshmallow fuzziness I now have, but at this stage I have it set with six and 12 string acoustic, clean electric, crunch rhythm, overdriven / phased electric, Sitar, Lead and Lead/harmony sounds in the one set, and all the guitars seem to be switching from between models instantly, flawlessly.

Cheers groovers.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...