Jump to content
mjkellerii

G10T with Spider V - Update

Recommended Posts

I have a new G10T - no problems with it at this time - but would like to make sure that the firmware is up to date.  The G10T was received as a PROMO with my vew Spider V 240 - so I do NOT have the receiver.  Can I get the USB adapter and get it updated with the Line6 Updater that way?

Share this post


Link to post
Share on other sites

Nothing on this?  Also opened a support ticket - been 5 days and no answer.  Wow - thought this was a pretty straight forward question...

Share this post


Link to post
Share on other sites

The Spider has a USB connection on the back. Have you tried connecting via usb with the Line 6 updater with the G10T plugged into the amp to see if the Updater sees the G10?

Share this post


Link to post
Share on other sites

You can open up a support ticket with Line 6, and they can walk you through the process if it can be done. I don't have a Spider, so I am not sure. 

Share this post


Link to post
Share on other sites

Yep. Done that. No reply on ticket yet. Been open over a week. No emergency here though. I am calm cool and collected. All is working so no need to trash talk. 😀

Share this post


Link to post
Share on other sites

Finally got an answer from support. They said there is no way to update without the receiver. Mine however has no problems and was apparently shipped with the latest firmware. They indicated that there were no updates expected. Not sure that is really a great answer - but so it goes.

Share this post


Link to post
Share on other sites

Did you have any problem getting your G10 to work?? I just got mine with the free promo. Got a Spider v 240. Plugged in the g10 and let it charge (in amp). Plugged into the guitar, light came on green but i get no sound. I tried on all 3 of my guitars and none of them are getting any sound.

Share this post


Link to post
Share on other sites

I did have an issue once where I had charged it in the amp and then unplugged it and turned off the amp.  When I went to use it I plugged it into the guitar and powered the amp on and got no sound.  Resolution was to plug the G10T into the amp - and after a few seconds the charging light comes on.  Then unplug it and plug back into guitar.  Apparently the G10T and the receiver built into the amp negotiate the channel they use to communicate when the G10T is plugged in...

Share this post


Link to post
Share on other sites

I want to use a G10T to send the signal from my JTV Guitar to my Spider V 120 and I have three questions:

 

1) Will the G10T power the JTV?

 

2)  If not, do I need to have my battery in the JTV to drive the guitar?  or . . .

 

3)  In the alternative, can I use a TRS cable to my XPS box and plug the G10T into the i/4" output on the XPS box and have it all work?

 

Thanks, Scott

Share this post


Link to post
Share on other sites

I want to use a G10T to send the signal from my JTV Guitar to my Spider V 120 and I have three questions:

 

1) Will the G10T power the JTV?

 

2)  If not, do I need to have my battery in the JTV to drive the guitar?  or . . .

 

3)  In the alternative, can I use a TRS cable to my XPS box and plug the G10T into the i/4" output on the XPS box and have it all work?

 

Thanks, Scott

1. G10T doe not output any power. 

2. You will need the JTV battery to drive the modeling, not necessary for magnetic pickups

3. I am not familiar with the Variax XPS box. I would think that it would work though.  

Share this post


Link to post
Share on other sites

Thank you.

 

I was trying to confirm I can use the G10T in my JTV and get all the correct modeling sounds.    So you have confirmed I will get the modeling sounds if I have the battery in the guitar.  But I suspect the XPS Box will not work with the G10T because the G10T would have to go in the same 1/4" connection on the JTV that the cable to the XPS Box has to use.   Now that I think about it that only makes sense.  There is only one 1/4" out on the guitar and either the TRS cable or the G10T will have to use it.   :)

 

Thanks again for your response.  It helped me think through the issue.  I guess the G10T will only transmit the modeling sounds from the JTV if the battery is powering the guitar.  

 

Regards, Scott   :)

Share this post


Link to post
Share on other sites

 

G10T questions.

 

I recently bought just the G10T and am within a window to return it and upgrade to the G10 but have a few questions as to why or why not to buy the G10?

 

1) Obviously ... the only way to upgrade the G10T firmware is with the G10 Bass Unit? A very bad decision on Line 6 for doing that to us? Might be part of my decision to upgrade to the G10 but not sure if it is really necessary based on a firmware upgrade path only?

 

2) As I understand it, with the G10 you can then obviously work the G10T with any amp? Am I correct in that? Without the G10 (and only the G10T) you are stuck with only being able to use it with a Spider V amp? Am I correct with that?

 

3) Assuming that you have the G10, if you don't have the G10 Base Unit on, you can still go directly to the Spider V with the G10T (as I am doing now). Correct?

 

4) Do charging times improve with the base unit vs using the Spider V amp?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×