Jump to content
kwhinz

Helix LT issues with USB connectivity (Line 6 Updater, Helix Editor)

Recommended Posts

Working through issues with my brand-new Helix LT, so far Line 6 Customer Support has been quick to engage and support:

  1. Initially the Helix LT was unable to connect to either Helix Editor or Line 6 Updater applications - first with a MacBook Pro laptop running MacOS El Capitan.  Switching to an iMac running MacOS Sierra, I was able to successfully update the Helix LT to firmware version 2.21.0.  I subsequently updated the operating system on the MacBook Pro laptop to Mac OS Sierrra.
  2. Now the Helix LT will temporarily connect to the computers with Helix Editor software, then dis-connect with a yellow-bar error message stating "Service is not online."  Subsequent attempts to connect are unsuccessful, sometimes with an error message stating "Cannot connect to device."  Both computers, two USB cables supplied with Line 6 hardware, all available USB ports on the computers... same dealio.  Not working!!
  3. My original Helix Floor unit connects successfully to both computers - with both of the USB cables I have - and there appear to be no issues with navigating the setlists, presets, etc.  Exporting the files to the local storage disks also works OK.  NO CONNECTIVITY ISSUES WITH THE ORIGINAL HELIX FLOOR.

Curious to see if other early adopters of the newly-released Helix LT are experiencing similar problems with USB connections and Helix Editor + Line 6 Updater applications.  Possibly this is more specific to Apple/Mac devices & not Windows/PC devices??

 

Thanks for any helpful input,

 

KWH

  • Upvote 1

Share this post


Link to post
Share on other sites

I had a similar issue with my LT,  my MAC never recognized it , and after a few general advices from Line 6 support, the result was:
«OK, please contact us again if the next update still doesn't fix the problem, although this still seems like a USB issue to me»

Share this post


Link to post
Share on other sites

My Helix Floor I bought this past November has never had luck with USB connectivity. It connects long enough to transfer a few presets but that's it. It happens with all computers, Windows 7, 8, 10, OSX.

 

I opened a support ticket and they're telling me to send it in and expect to wait 2 to 4 weeks..

Share this post


Link to post
Share on other sites

This is poor driver implentation from Line 6. USB...UNIVERSAL SERIAL BUS. Means just that, UNIVERSAL.

It should never be an issue with Windows connecting to a USB device. I have not seen an issue with USB connectivity in years or in decades. I asked Line 6 to give me the name of a PC laptop that would work 100% for sure, the support person said, "If you're curious, I've never had any driver or connectivity issues on my Lenovo Think Pad here at my desk.

works."   I am NOT curious, I need a product that WORKS. I'm still trying to get Line 6 support  stand behind their product (Helix). Clearly this is a issue that many people are encountering.

 

Frankly this is unacceptable.

Share this post


Link to post
Share on other sites

wow... only the actual cable and ports are universal.... all software interfaces need tweaked for the host operating system....

just added some reality to your post....

plenty of USB devices require driver updates to work... 

please continue working on your issues with the support team.... 

i understand you're not happy with things as they are, but that doesnt mean we get to make up facts about how USB works.

 

This is poor driver implentation from Line 6. USB...UNIVERSAL SERIAL BUS. Means just that, UNIVERSAL.

It should never be an issue with Windows connecting to a USB device. I have not seen an issue with USB connectivity in years or in decades. I asked Line 6 to give me the name of a PC laptop that would work 100% for sure, the support person said, "If you're curious, I've never had any driver or connectivity issues on my Lenovo Think Pad here at my desk.

works."   I am NOT curious, I need a product that WORKS. I'm still trying to get Line 6 support  stand behind their product (Helix). Clearly this is a issue that many people are encountering.

 

Frankly this is unacceptable.

Share this post


Link to post
Share on other sites

That's what I said...it's driver issue. USB is Universal Serial Bus. And MANY people report it. If they cant give me a certified computer that will 100% work with Helix (not an anecdotal statement) what does that mean? Am supposed to HOPE it will work with another computer? I offered to BUY a laptop specifically for Helix/Editor with a Line 6 guarantee it would work. So far no answer ...except anecdotal. Is this professional equipment?

  • Like 1

Share this post


Link to post
Share on other sites

That's what I said...it's driver issue. USB is Universal Serial Bus. And MANY people report it. If they cant give me a certified computer that will 100% work with Helix (not an anecdotal statement) what does that mean? Am supposed to HOPE it will work with another computer? I offered to BUY a laptop specifically for Helix/Editor with a Line 6 guarantee it would work. So far no answer ...except anecdotal. Is this professional equipment?

 

Although there are people that report having problems with the USB port, the vast majority of us have never had any probems.  I own two Helix units and commonly plug them into a desktop, a laptop, and a tablet computer all running Windows 10 all from different manufacturers.  I've never had a single problem with connectivity.  If there were an issue with the design of the USB this would not likely be the case.

 

The three situations I know of that have been common issues with the USB connection for people is plugging into a USB hub device rather than a direct USB (remembering that in many cases manufacturers use a hub design to provide additional USB ports when only one or two are actually direct), the supplied USB cable that came with the Helix is sometimes faulty, and various problems with older versions of operating systems on both the PC and Mac.

 

Whether it's a driver issue or not there's certainly not enough information to determine that from any anecdotal evidence that's been posted here or on other forums.  There are way too many variations in the implementations of computers, operating systems, virus protection schemes, etc. to jump to that conclusion. 

Share this post


Link to post
Share on other sites

Great to hear.  

But it still is not connecting. I offered to buy a laptop that Line 6 will certify to comply. Days go by with no
support  solution. What do YOU now suggest. Purchasing a $700 laptop just HOPING it will work?

Share this post


Link to post
Share on other sites

Great to hear.  

But it still is not connecting. I offered to buy a laptop that Line 6 will certify to comply. Days go by with no

support  solution. What do YOU now suggest. Purchasing a $700 laptop just HOPING it will work?

 

After re-reading your initial post and seeing that you also have a full Helix that's been connecting, that isolates the problem to the LT unit.  Have you made that clear to Line 6 support?  From a software engine perspective there shouldn't be any difference between the two.  The device drivers should be the same, etc.  Therefore I think all the evidence points to some hardware issue with the USB port on the LT.

 

I'd touch base with Line 6 and make sure they understand your full Helix works fine with the same cables, the same computer, and the same OS, but your LT doesn't.  That makes a BIG difference in isolating this problem.

Share this post


Link to post
Share on other sites

Thanks, and I know people here do care, but also defend Line 6.

 

Actually only have the one Helix LT. But I do use my Variax with Workbench USB. No problems. But with the Helix LT the USB crashes, meaning out of the blue the yellow exclamation mark in device manager (and of course the Helix device not found message in editor).  I am willing to accept that everyone with USB issues (including me) are just anecdotal evidence. BUT Line 6 needs to supply a  "certified in compliance with their hardware" list of laptops. How else are we to be asssured? 

Oh yeah...UNIVERSAL serial bus. That's the point of Universal Serial Bus. (yes, among other things).

 

I am willing to cross ship they can charge my credit card until they receive the old one back. But I don't believe it's the hardware.

I am going all out to solve this...but  i am disapointed with support, for sure.

 

Just so its not all negativity here...I use the Variax JTV59 all the time, great build quality, same with the Helix LT.

Share this post


Link to post
Share on other sites

Line 6 cannot give you a list of laptops that will 100% work through USB. Nobody that makes USB devices can give you such a list. The "universal" in USB is referencing the industry physical standards concerning connection type and pin-out, cables, and communication protocol. It in NO way indicates that a Universal serial device will work with every computer with a USB port. 

 

I recommend continuing to work WITH Line 6 in resolving your issue rather than stomping your foot. Stomping of the foot usually ends up getting you less than stellar support with ANY company. 

 

Just my $0.02...

Share this post


Link to post
Share on other sites

Great to hear.  

But it still is not connecting. I offered to buy a laptop that Line 6 will certify to comply. Days go by with no

support  solution. What do YOU now suggest. Purchasing a $700 laptop just HOPING it will work?

You could try posting a thread on this forum asking what laptops users have 100% success with. Just a thought. 

Share this post


Link to post
Share on other sites

Line 6 cannot give you a list of laptops that will 100% work through USB. Nobody that makes USB devices can give you such a list. The "universal" in USB is referencing the industry physical standards concerning connection type and pin-out, cables, and communication protocol. It in NO way indicates that a Universal serial device will work with every computer with a USB port. 

 

I recommend continuing to work WITH Line 6 in resolving your issue rather than stomping your foot. Stomping of the foot usually ends up getting you less than stellar support with ANY company. 

 

Just my $0.02...

 

communication protocol ...exactly the issue. The idea of USB (amonst many things) was that IRQ settings and hardware configuration etc., would comply with the USB protocol. In this instance Windows Code 10  is saying Windows CANT COMMICATE with device. IE: device wont start. NOT that the device/software/driver etc., will work...JUST that it is in communcation (IE: NO exclamation mark in device manager).

 

 DO  NOT lecture me with "stomping foot" comments this is $1000's of dollars of hardware and time wasted.

  • Upvote 1
  • Downvote 1

Share this post


Link to post
Share on other sites

You could try posting a thread on this forum asking what laptops users have 100% success with. Just a thought. 

Thanks...good thought. But of course it would just be annectdotal. I really need Line 6  to stand behind its product.

Share this post


Link to post
Share on other sites

Line 6 (Or Line Suck) I face a lot of issue from Helix. 
1. Pedal screen strip (dead pixel)

2. Software error 
3. USB port with Mac always disconnect 

I have charged for new one 3 unit.
Every unit have problem. 

You must Improve production quality.

Share this post


Link to post
Share on other sites

phew so it was a faulty factory USB cable for me. but I presume you all already tried that option…

Share this post


Link to post
Share on other sites

I thought I'd share my experience. Just received the LT today. Updating the firmware to 2.30 and installing the driver & HX Editor was piece of cake. Then after playing with it for an hour it just showed the No Device Connected red sign. I tried everything from rebooting the LT, to rebooting my PC, changing the USB cable, plugging it to all combinations of HUB/USB2/3/etc, uninstalling and reinstalling the driver, hard reseting the LT. Finally I thought how about the usual Windows 10 trick: Run as Administrator - and voila, it worked. So look for the %PROGRAMDATA%\Microsoft\Windows\Start Menu\Programs\Line6\HX Edit\HX Edit.lnk link, right click on it, choose Properties, and on the Compatibility tab, check the last check box 'Run as Administrator'. Worked for me.

Share this post


Link to post
Share on other sites

Since i have my LT i have also problems with the unit ... not so much with disconnecting (happened 3 times) but more with the audio using the LT interface with backingtracks. The ( Windows PC) audio stopped working after a while and i need to restart the PC. The other problem is that the Updater doesnt work on 2 PCs ... it only works with an 8 (!) year old laptop ... Ive used many other different Effects units with USB support but ive never faced any problems with all my PCs. 

 

As only LT users reporting similar USB problems, it could be either a software problem (Line 6 USB / Audio driver) or a  hardware problem so that they maybe used different (cheaper) USB connectors in all LT units. 

 

I wish Line 6 would give us a little bit more support here 

Share this post


Link to post
Share on other sites

Just an update on my situation, I've sent my Helix in for repair this August and it came back with the same problems. They sent me a brand new replacement a week ago and it's connecting great for long lengths of time with no drop outs

Share this post


Link to post
Share on other sites

Just an update on my situation, I've sent my Helix in for repair this August and it came back with the same problems. They sent me a brand new replacement a week ago and it's connecting great for long lengths of time with no drop outs

 

Sounds for me as a proof that its a hardware problem of the LTs

Share this post


Link to post
Share on other sites

Just got mine and turned it on. Same problem for me. I tried my Firehawk USB cable into the 2.0 USB and it worked fine. Whew!!!  Firmware 2.53.

Share this post


Link to post
Share on other sites

OMG. I bought this device 3 weeks ago. In the Netherlands. Came with firmware 2.10. So, I wanted to update to 2.54.

Lots of issue's with the USB connection. I was really p.ss.d off.

When I downloaded some presets from CustomTone, same issue's.

I just made a backup before importing the downloaded presets and again, fail. I had all my selfmade snaps gone. Backup did not work because of timeout.

And now I read, start HX edit as Administrator.!! Man, that works. I'm so happy, got my backup working.

I'll take a beer now.

Share this post


Link to post
Share on other sites

I have the same problem with my Helix LT.

 

I have an Macbook Pro 15" (Mid2012) the connection drops every couple of minutes. I believe it is more of an issue when trying to connect using USB3.0 and 3.1(A-type)

 

Nothing can make it work, I've tried different USB ports, different USB cables, different OS (ElCapitan, Sierra, High Sierra).

 

On the other hand the connection works like a charm in both my macmini and macbook air, go figure.

Share this post


Link to post
Share on other sites

I had the same problem. When I looked at the device manager and the driver for the helix ran the trouble shoot on that driver it came back and said that helix is not compatable with usb3.0. I don't know if that's true or not, I have a DEll laptop running Wundows 10. But I plugged the Helix into a usb hub and it now works fine.

Share this post


Link to post
Share on other sites
On 6/8/2018 at 4:16 AM, ioannisfidelis said:

I have the same problem with my Helix LT.

 

I have an Macbook Pro 15" (Mid2012) the connection drops every couple of minutes. I believe it is more of an issue when trying to connect using USB3.0 and 3.1(A-type)

 

Nothing can make it work, I've tried different USB ports, different USB cables, different OS (ElCapitan, Sierra, High Sierra).

 

On the other hand the connection works like a charm in both my macmini and macbook air, go figure.

 

Same here.  On my MacBook Pro, the connection drops somewhat randomly.  Sometimes in a minute or 2.  Sometimes after 10 minutes.  Sometimes when I switch to a different app.  Sometimes when I am exclusively in HX Edit.  I've tried turning on and off various things such as energy saver and bluetooth on the Mac, but nothing helps.  I tried different USB cables and different ports, all with the same results.

 

So today, I installed HX Edit on my wife's MacBook Air, which is actually ~2 years older than my MacBook Pro (both on High Sierra).  Not 1 single dropout, except for when the MacBook Air went into sleep mode.  Even then, the reconnection was very fast.  In fact, I even turned the energy saver off at 1 point and left the Helix and HX Edit running for over an hour.  When I returned the Helix and HX Edit were still connected.

 

The good news for me is that it does not appear to be an issue with the Helix hardware (albeit, it could be some incompatibility, but I know it can work as designed).  If anyone else has done some troubleshooting and reached the bottom of this, please share!

Share this post


Link to post
Share on other sites

As an update...I think my issue is software related.  I've not completely pinpointed it, but it actually appears that I lose connectivity to HX Edit whenever I get an email!  Does that seem possible?

Share this post


Link to post
Share on other sites

I just have bought second hand Helix LT purchased in March 2017. The same issue with Windows 10: Hx Edit losing connection every couple of minutes, crackling jitter noise when used as audio interface. ). I tried reinstaling software, diifferent USB ports, different computer...
...after replacing USB cable the problem is gone! :)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×