Jump to content
Sign in to follow this  
Fieldstone

Relay G10 always plugged into outlet.

Recommended Posts

Love my G10...works wonderfully. My question is...I have it plugged into power 24/7. Does anyone know any reason why this might cause issues? Shorter battery life or overheating or ? No issues...and I use it several times a week during practice...and it goes to a solid green a few minutes after putting the transmitter back into base. So it appears to be working fine...just want it to last.

Thanks

Dave

Share this post


Link to post
Share on other sites

Love my G10...works wonderfully. My question is...I have it plugged into power 24/7. Does anyone know any reason why this might cause issues? Shorter battery life or overheating or ? No issues...and I use it several times a week during practice...and it goes to a solid green a few minutes after putting the transmitter back into base. So it appears to be working fine...just want it to last.

Thanks

Dave

Most rechargeable batteries last longer if you drain them "fully" before recharging. I am assuming this is the case with the transmitter. I have my base unit connected to a power strip so I can turn it off. Mine stays in my guitars, I play with mine all week (2-3 hours during the week), and just recharge Saturday night before church. The unit is supposed to have 8 hours of play time, so I am probably not fully draining mine either. 

Share this post


Link to post
Share on other sites

I leave mine plugged into the wall with the transmitter inserted in the base.  I've experienced no issues and I've had it for a year now.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×