Jump to content
themetallikid

2 Topics: Copy/paste blocks and Solo performances

Recommended Posts

So...been floored with the Helix so far....even my sound guy was impressed.  Basically with my first batch of patches he had me almost flat (the flattest he has ever ran me).  Just a small boost around the 315hz mark.  He always seems to add some of that to my signal.  Not sure if its the EMG's or just how I dial it in, or if that's what helps separate me from the other guitar player...oh well....

 

 

I move on....

 

 

So while creating my presets, I ran into times where I wanted to copy a layout from one preset, but copy the amp/cab block (or other effect) from a different preset.  It would allow me to copy the block, but would not allow me to paste it into the new patch.  Not sure if I'm doing something in the incorrect order, but 1) choose old preset, 2) right click > copy, 3) choose new preset, 4) right click > paste -  seems pretty straight forward.  And it worked sometimes, just not when I was on a roll and wanted to use it. 

 

 

 

 

My second topic - have an acoustic performance Thursday, and there is a chance that I'll be going solo....would like to get the Helix setup with running guitar/vocals through it.  I think there is a guide in the cheat sheet to do this, but does anyone have any tips on this? 

Share this post


Link to post
Share on other sites
So while creating my presets, I ran into times where I wanted to copy a layout from one preset, but copy the amp/cab block (or other effect) from a different preset.  It would allow me to copy the block, but would not allow me to paste it into the new patch.  Not sure if I'm doing something in the incorrect order, but 1) choose old preset, 2) right click > copy, 3) choose new preset, 4) right click > paste -  seems pretty straight forward.  And it worked sometimes, just not when I was on a roll and wanted to use it.

 

This is what caught me with this.

 

After you have pasted the block in a new preset, you need to immediately save that preset.

 

I would copy a block from one patch-go to new patch and paste the block-go back to the old patch to copy a new block-go back to the new patch and the block I thought I had put in there would be gone. Well, it doesn't automatically save the patch or put the pasted block in a buffer. So when you leave the new patch to go to another, it doesn't keep any changes you've made if you haven't saved it. Save save save.

 

Or (after reading your patch closer) could your new patch just not have enough memory for that block? Before you try to paste a block, go to the effects selection area and see if the effect in the block you want to paste is grayed/dimmed out, indicating there's not enough memory left for it. If that's true, you won't be able to paste the block with the same effect in it.

Share this post


Link to post
Share on other sites

My second topic - have an acoustic performance Thursday, and there is a chance that I'll be going solo....would like to get the Helix setup with running guitar/vocals through it.  I think there is a guide in the cheat sheet to do this, but does anyone have any tips on this? 

 

There are two paths each with it's own input. Make one input the guitar and one the mic. Select the effects you want for each path and mix and pan at the output of each path. Make sure the output for each path is the same.

Share this post


Link to post
Share on other sites

Hey Brue - There is sufficient memory, as I'm able to just drop that same block in and edit from scratch.  I have been saving after the times it does let me paste it in.  However, what I notice is that when I go to 'paste' and right click, 'paste' isn't even an option to choose. 

Share this post


Link to post
Share on other sites

Hey Brue - There is sufficient memory, as I'm able to just drop that same block in and edit from scratch.  I have been saving after the times it does let me paste it in.  However, what I notice is that when I go to 'paste' and right click, 'paste' isn't even an option to choose. 

 

Hmmm. That is weird. Are your Helix and Helix editor at the latest versions? If one is on the latest version and the other isn't, that can give you issues.

Share this post


Link to post
Share on other sites

they should be (?)......I thought I installed the latest editor version, but the firmware should be the latest as it was updated before it shipped to me. 

Share this post


Link to post
Share on other sites

Well the editor should be Ver. 2.21, the Helix firmware Ver. 2.21 and the driver Ver. 1.86. I guess check those out for now. You may want to try to reinstall the firmware and if you do, don't forget to reset the Global settings and restore the factory presets by holding down footswitches 9 & 10 while powering the unit on. You do this after you install the firmware. You WILL lose all of your personal patches Global settings and IR's (if you havge any) when you do that so save the patches to your computer and write down your Global settings and IR locations. There is no way around it. Right now, you have to lose all of your settings, patches etc. to install new firmware because you HAVE to do this Global reset.

Share this post


Link to post
Share on other sites

I have the same problem pasting amp blocks from one patch to the other in Editor, really weird.

I have discovered that it then still works on the Helix itself, So I just do the past on the Helix after right click-copy on the PC.

It never fails so it'sa fine workaround but there's something wrong!

Share this post


Link to post
Share on other sites

oh, so you can copy/paste right through the on board editing screens as well?  I have been doing most of my editing via the pc, and any quick adjustments via the onboard one.  I didnt search out the copy/paste function on the screen.  I'll have to look for that, I'd be ok with that as a work around.  

Share this post


Link to post
Share on other sites

oh, so you can copy/paste right through the on board editing screens as well?  I have been doing most of my editing via the pc, and any quick adjustments via the onboard one.  I didnt search out the copy/paste function on the screen.  I'll have to look for that, I'd be ok with that as a work around.  

Yes, you can copy/paste right on the Helix itself. I don't use the editor much because I feel it is necessary to be familiar with all the controls directly on the Helix. I don't play live with the editor, so I want to know how to do things quickly directly on the Helix. 

 

You can copy/paste a block within a preset as well as to other presets. Just hit action>copy go to where you want to paste it, hit action>paste. 

Share this post


Link to post
Share on other sites

Yeah I made it a point to become familiar with doing quick edits for live use, as adjusting patch volumes at home is not the easiest to translate to live shows. I can get ball park, but knowing how to adjust on the fly helps.  Just wasn't sure you could do that via the onboard.

Share this post


Link to post
Share on other sites

I've seen this issue and encounter it frequently.  It also occurs when copying blocks to blank presets (i.e. copy an amp block, go to the blank preset, past is not an option).

 

I'm assuming it is an editor bug.  It's a bit annoying - I'll have to go back and attempt to copy the block 3-4 times on average before it works....

Share this post


Link to post
Share on other sites

I have never encountered this phenomenon. And I copy and paste blocks a lot. I wonder what the issue is. I'm using Windows 7. Could it have something to do with an issue with other operating systems? Windows 10, Mac? I can't think of anything else. It's obviously happening so I wonder what's so special about what I'm using. It's just an old off the shelf computer.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...