Jump to content
plumber

FX loops quality

Recommended Posts

Hi

 

First post on this forum, generally loving the helix

 

However trying to put the my strymon El Cap and DIG in the effects loop seems to show up a dirty return signal

 

Anyone experienced this

 

Particularly the DIG which should be pristine and its noticeably not

 

I have the global send returns set to instrument- tried line level and that was worse

 

Any help very welcome

 

Cheers

 

Lorne

Share this post


Link to post
Share on other sites

I have 4 Strymon pedals thru the Aux sends and returns on Helix and they sound wonderful.

 

I have no idea. My Strymon "FX/Loops" are set to 48k sample rate and instrument.

Share this post


Link to post
Share on other sites

Hi, plumber, welcome to this forum!

No problems Strymon pedals here.

Double check (patch) cables, in/output volumes...

Try to place the effect loop at another position in the path...

Adjust send /return levels (manual, p. 30)...

Share this post


Link to post
Share on other sites

The sample rate setting only affects the AES/EBU output. It doesn't change the internal processing or output at any of the analog outputs at all.

Share this post


Link to post
Share on other sites

The issue with the noise and effects isn't because of the loops themselves. It really only shows up if you put an OD/distortion pedal in front of an amp model, specifically, some of the models with higher noise floors. It's just that any additional noise from the pedal itself is being amplified slightly in the A/D conversion process and then that is being amplified by the amp model itself. If you put loops after the amp model, they are pretty much dead quiet.

Share this post


Link to post
Share on other sites

I have a Red Witch Fuzz God 2 in one of my loops and when I leave the oscillator switch engaged it is super noisy. I do not have a problem with it creating noise when the loop is disengaged. 

 

Could it be related with whether or not trails are set to on for the loop? I make sure mine are off for drive pedals.  

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...