Jump to content
the29band

Popping/Crackling in DT25 even after tube replacement and biasing

Recommended Posts

I got my DT25 tubes replaced (both preamp and power) with the following tubes below, earlier this week. I confirmed that Line 6 recommends these tubes. The tech had also biased the amp post replacement. 

 

http://www.musiciansfriend.com/accessories/electro-harmonix-el84-matched-power-tubes/210092000118185?source=3TEM5KTBK

 

http://www.musiciansfriend.com/accessories/electro-harmonix-12ax7eh-preamp-tube?source=3TEM5KTBK

 

However, the amp is making crackling noises in Class A/B mode but NOT in Class A.

 

Thoughts? 

Share this post


Link to post
Share on other sites

If it's not the tubes, then it can be one of two things. And that will have to be serviced by

an Line 6 authorized service center.

 

Share this post


Link to post
Share on other sites

Does it crackle without anything plugged in? I had similar issue and found out it was a dodgy instrument cable.

Share this post


Link to post
Share on other sites

Wondered that myself, but it only occurs with hummers.

If it was the cable I would expect it pop and crackle on both hummer and single coil. 

 

Unless there's something odd with the cable ground, that it would only occur with the humbuckers.

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...