Jump to content
sech

Helix S/PDIF input oversight by LINE 6?

Recommended Posts

Although the Helix has an S/PDIF input mounted on the unit, other than the back panel descriptions in the manual (item 29), there is nothing else addressing this input. The global settings panel on page 50 of the manual only mentions digital output level nothing about inputs. On the firmware side, the home screen for global settings also defaults to digital output level, nothing about input level or routing. Also, when trying to access S/PDIF input by creating a path within a patch, the input block will not give the option to select S/PDIF input (or digital in). So, is this an oversight or am I missing something?

Share this post


Link to post
Share on other sites

Although the Helix has an S/PDIF input mounted on the unit, other than the back panel descriptions in the manual (item 29), there is nothing else addressing this input. The global settings panel on page 50 of the manual only mentions digital output level nothing about inputs. On the firmware side, the home screen for global settings also defaults to digital output level, nothing about input level or routing. Also, when trying to access S/PDIF input by creating a path within a patch, the input block will not give the option to select S/PDIF input (or digital in). So, is this an oversight or am I missing something?

 

If you go to the input block you can change it to Digital (S/PDIF or AES/EBU) at least on my Helix Rack you can. It's the 13th option.

Share this post


Link to post
Share on other sites

You know, I can tell you guys are pretty good with this thing but I'm going nuts. I cannot find a selection for spdf in for an input block anywhere, I went to templates and found one patch (stereo mixer) that allowed me to change the input block to spdf in so I tried to copy it and bring it to another patch and no dice...I'm running 2.21.0 firmware if that helps!

Share this post


Link to post
Share on other sites

Select the input block, then turn the big selection wheel. You will then see a large selection of inputs to choose from. What you are looking for should be available.

 

All other blocks usually have you choose a model before putting it down. The input blocks are already in place. You are not replacing them. Just select them, and cycle through them with the selection knob.

Share this post


Link to post
Share on other sites

You know, I can tell you guys are pretty good with this thing but I'm going nuts. I cannot find a selection for spdf in for an input block anywhere, I went to templates and found one patch (stereo mixer) that allowed me to change the input block to spdf in so I tried to copy it and bring it to another patch and no dice...I'm running 2.21.0 firmware if that helps!

 

So you are on Helix Floor (not LT) and you are navigating to the input block and it is not letting you select SPDIF in?

Share this post


Link to post
Share on other sites

yes, I'm using the Helix floor and no [spdif in] listed in the dropdown options when creating an input block. I did find one instance in templates in a patch called "stereo mix" where I could find the digital input option. I copied the patch and edited to allow testing and it worked. Also, not sure why the [spdif in] is not showing up in my global settings I can only access control for the digital output level nothing for the input. I had to control the input level by adding a block to boost the volume within the one patch that allows me have a digital input...btw, the reason I wanted to use the digital in is to have a way to bring in background vocals from a harmonizer and it actually worked. So I'm stretching the capabilities of the Helix beyond guitar effects to allow me to mix backing tracks (USB 1/2 in), lead vocals (mic in) and harmonies (S/PDIF in) eliminating an external mixing board. Not too shabby for the one man band although a couple of minor firmware upgrades would make it even better!

Share this post


Link to post
Share on other sites

yes, I'm using the Helix floor and no [spdif in] listed in the dropdown options when creating an input block. I did find one instance in templates in a patch called "stereo mix" where I could find the digital input option. I copied the patch and edited to allow testing and it worked. Also, not sure why the [spdif in] is not showing up in my global settings I can only access control for the digital output level nothing for the input. I had to control the input level by adding a block to boost the volume within the one patch that allows me have a digital input...btw, the reason I wanted to use the digital in is to have a way to bring in background vocals from a harmonizer and it actually worked. So I'm stretching the capabilities of the Helix beyond guitar effects to allow me to mix backing tracks (USB 1/2 in), lead vocals (mic in) and harmonies (S/PDIF in) eliminating an external mixing board. Not too shabby for the one man band although a couple of minor firmware upgrades would make it even better!

 

OK, just sat down to my Helix Rack to test this.

 

I have a 4-parallel path patch I made where I can change ANY of the 4 inputs on the 4 paths to that digital S/PDIF - AES input (I can use AES input on the Rack, i know you can't but it should still work the same.

 

BUT! if I go to a blank patch and leave path 1 at Multi and then try and change path 2 to that digital input, it doesn't come up as an option.

 

YOU SIR, have discovered a bug and I would open a ticket with line 6.

 

It seems it's a feature that is missing that maybe you need.

 

Very annoying! But no, you are NOT CRAZY. Well, I hope you ARE crazy, because it's way more fun, you just are not crazy in this particular regard.

Share this post


Link to post
Share on other sites

yes, I'm using the Helix floor and no [spdif in] listed in the dropdown options when creating an input block. I did find one instance in templates in a patch called "stereo mix" where I could find the digital input option. I copied the patch and edited to allow testing and it worked. Also, not sure why the [spdif in] is not showing up in my global settings I can only access control for the digital output level nothing for the input. I had to control the input level by adding a block to boost the volume within the one patch that allows me have a digital input...btw, the reason I wanted to use the digital in is to have a way to bring in background vocals from a harmonizer and it actually worked. So I'm stretching the capabilities of the Helix beyond guitar effects to allow me to mix backing tracks (USB 1/2 in), lead vocals (mic in) and harmonies (S/PDIF in) eliminating an external mixing board. Not too shabby for the one man band although a couple of minor firmware upgrades would make it even better!

Nice catch. I didn't get a chance to sit down and look for it. 

 

Yes, start up a support ticket with Line 6 with your details so they will be aware of it. 

Share this post


Link to post
Share on other sites

I am 4 states away from my Helix, but I wonder if you guys moved path 1 down to path 2. (by way of copy & paste) keep path 2 at multi, then try to change path one input to digital s/pdif?

 

Mainly just curious...

Share this post


Link to post
Share on other sites

I am 4 states away from my Helix, but I wonder if you guys moved path 1 down to path 2. (by way of copy & paste) keep path 2 at multi, then try to change path one input to digital s/pdif?

 

Mainly just curious...

 

Still an omission I'm sure they'll want to fix, but yes, that should actually work.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×