Jump to content
ponsolle

Tuner accuracy

Recommended Posts

Hi all!

I ve just tried tout compare the tuner of the helix and my polytune and while it is perfectly in tune with the plytune i am slightly out of tune with the helix...

Somebody to explain?

Thx

Share this post


Link to post
Share on other sites

Make sure the Input setting on the Helix preset is set to a single value, matching the physical input of the instrument you are tuning. For instance, set it to Guitar not Multi.

Share this post


Link to post
Share on other sites

Several threads about this. To get the tuner to work you need to roll back the tone knob on your guitar, change to neck pickup, hit the strings gently, hold your breath and stand on one leg. Easy if you have the time.

Share this post


Link to post
Share on other sites

I have no tuning anomalies at all with Helix tuner.

Polytune is so sweet though that if you have it, just use it.

Share this post


Link to post
Share on other sites

I have no issues with the helix tuner, I have the polytune and boss tuner.... but really...don't need them in live gigs...maybe not the best tuner in the world but surely usable

Share this post


Link to post
Share on other sites

I had a bit of a panic moment with my tuner this morning... Plugged In, went to fine-tune and despite the fact that the guitar was basically in tune it was indicating extremely Sharp....

Took me a couple minutes to figure out that when I entered tuning mode I had drug a patch cable across the knob that adjusts the tuning frequency and moved it to 432 versus the usual A-440...

For a minute I thought "damn the tuner issue"!!

Otherwise I'very had zero issues with it.

Share this post


Link to post
Share on other sites

I had a bit of a panic moment with my tuner this morning... Plugged In, went to fine-tune and despite the fact that the guitar was basically in tune it was indicating extremely Sharp....

Took me a couple minutes to figure out that when I entered tuning mode I had drug a patch cable across the knob that adjusts the tuning frequency and moved it to 432 versus the usual A-440...

For a minute I thought "damn the tuner issue"!!

Otherwise I'very had zero issues with it.

Lol...with any sudden weirdness, I always assume user error until it's proven otherwise. My personal favorite is trying to chase down the cause of complete silence after I've powered everything up...plugging in the guitar seems to help with that. ;)

  • Upvote 2

Share this post


Link to post
Share on other sites

Lol...with any sudden weirdness, I always assume user error until it's proven otherwise. My personal favorite is trying to chase down the cause of complete silence after I've powered everything up...plugging in the guitar seems to help with that. ;)

 

I cannot tell you how often I've found myself messing around with cables and pedals only to realize my guitar wasn't plugged in.

Share this post


Link to post
Share on other sites

I cannot tell you how often I've found myself messing around with cables and pedals only to realize my guitar wasn't plugged in.

Well at least I'm not the only one losing my marbles...;)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×