Jump to content

Problems using helix as a USB interface


Recommended Posts

After about 8 or 9 hours of Protools running I start getting intermittent static out of the monitors no matter where the audio is coming from. 

I'm not a recorder but I do work from home, sometimes I just leave pro tools running.


I have to reboot the machine to get rid of it. Win7/64. 

I've never notice the recording being out of time though.

Link to comment
Share on other sites

IF your DAW allows the following:


I use this in FL Studio, and it helps.  Sometimes I get cracks, and static from time to time.


Go into your ASIO, or Driver settings in your DAW.  Choose a different driver all together, wait the couple of seconds, then switch back to your Helix ASIO driver.  FL Studio allows me to do this if I choose either ASIO4Allv2, or FL ASIO. (just for a second) then switch back to Helix ASIO.  If I were to choose one of the other drivers during this time, it may bluescreen me, or just crash FLS. So be sure to save your work in your DAW before trying this.

It could be a power management issue, as well.


As far as recording being out of time your ASIO settings will more than likely be the culprit here, if they are set with a high buffer then what you record (even a dry track through usb7) will go through the system latency. I have my ASIO buffer set to 512. I rarely have to shift an audio recording due to a timing issue that isn't of my own mis-timed playing.  IF this isn't the case for your then there is something wrong with your setup else where. 

Link to comment
Share on other sites

Namely, 1) recorded tracks seems to be slightly out of time for some reason?


2) intermittent bursts of static


Anyone experienced similar?


Haven't had a problem with the actual recorded audio being out time.


I recently had a problem with crackling and static on win10 pro. On win7, same system, no problems with buffers as low as 64. I did eventually fix the problem on win10, but I'm uncertain as to what I did. I remember switching power profiles from balanced to high performance, and then editing the high performance profile a little bit. Also went into device manager and turned off allowing the computer to turn off usb hubs to save power; same thing under human interface devices.


In the system bios, you might look for spread spectrum options, which when enabled may reduce any electromagnetic interference.


DAW plugins can also contribute to crackling or static.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...