Jump to content
sidchip

Helix LT Momentary Footswitches as MIDI sometimes latching

Recommended Posts

Hello! I have a Helix LT, updated to latest version, 2.21 and I'm using it to send MIDI notes to my Sub 37. I've set them up in the Command Center and it works well most of the time. I've got the display set in Stomp mode so I can see the Notes each button is programmed to. These icons light up when depressed, and go dark when I lift off. However, sometimes throughout the night, they get stuck "on" . and clicking on them has no effect. I have to changes presets back and forth to get these to reset properly.

 

Please advise!

Sid.

Share this post


Link to post
Share on other sites

Try setting Helix MIDI Global Settings "PC Send" to Off by going to Menu Button > Global Settings > MIDI/Tempo > MIDI PC Send (Page 2) > Off

  • Upvote 1

Share this post


Link to post
Share on other sites

Thank you, I see there are a few MIDI options I don't think I'll be needing. I will try this tonight.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...