Jump to content

connecting a Flextone III XL to line 6 monkey / edit

Recommended Posts

Hi everyone,


I've bought a second hand Flextone III XL, i know it's kinda old now but i hope i can still use Line 6 edit to load custom tones, but the loading bar stops at 5 seconds, and a MIDI timeout error appears.


so i spent the night trying to connect my amp to my laptop in order to update the flash memory with line 6 monkey so maybe line 6 edit would recognize it.


I looked a lot of threads on this forum, i'm using the M-audio Uno, with the manufacturer's drivers, tried the safe mode Power + A ( then only the A button lights up ), and nothing happens


monkey does recognize my amp, but when i try to update ( with "update selection" and "update from file" ), I choose the second option ( install the new default patches )  it stops at "reading existing patches" then I get the errors :


Flextone 3 Update Failed.


(Code 8000720A) failed to save patches to local disk

(Code 8000900C) MIDI Device timed out waiting for response


Try the update again, making sure the cables are still connected.


Please, tell me what more can i try, i even tried a hard reset ( A + D + Power ), downloading the 1.0 file and loading it with monkey, nothing works.



Link to comment
Share on other sites

9/10 its the midi/usb cable. I use an MAudio Uno and it works with L6 gear. I learned the hard way by trying a ebay $2 special and it was driving me nuts with timeout errors. So try an M-Audio Uno. The Flex 3 still delivers the goods and is a good sounding amp when dialed in.

Link to comment
Share on other sites

  • 5 months later...
  • 1 month later...
  • 1 year later...

I have 3 Flextone IIIs.   One is the Flextone III XL (2x12) and the other two are the Flextone III+ (1x12).  Decent sounding inexpensive amps.  However, they are prone to MIDI communication problems.  About 5 years ago, one of the Flextone III+ models stopped communicating via MIDI.  Everything else continued to work just fine on that amp.  Interestingly, the other two Flextone IIIs continued to communicate via MIDI with the same computer and the same MIDI cables.  In other words, it's not the MIDI cable.  I have tried several different MIDI cables with the same result.  I have concluded that it's the circuitry inside the Flextone III itself that is causing the problem - something internal has failed.


About a year ago, the other Flextone III+ started doing the same thing, but the Flextone III XL continues to communicate just fine with the same computer and cables.


I did find a workaround, in order to get sounds into these defective Flextone IIIs.  It's a bit of a pain, but I've had it work several times now.  And for the record, I'm talking about the famous MIDI Timeout Error.  Mine hangs up at the 4 seconds left mark, and then that's it.  I use my Flextone IIIs with a Shortboard attached.


My solution has been this:

1.  Connect the Flextone III via Midi Cables/USB to a PC and turn on the Flextone III.

2.  Open Line 6 Edit on a PC.

3.  Open a saved sound patch within Line 6 Edit. 

4.  Watch the display of your Shortboard.  If the name of the activated patch appears in the Shortboard display, then the sound has indeed loaded into your Flextone III but is not saved yet.  Do not expect this to load on the first attempt.

5.  Try to Refresh the connection between Line 6 Edit and the Flextone III

6.  Before the system hangs up and gives you the MIDI timeout error, vary the position of the volume pedal on the Shortboard continously.  This gives Line 6 Edit some feedback and delays the timeout error.  Do this for a minute or so, checking the Display of the Shortboard. 

7.  When the name of the loaded Line 6 Edit patch appears in the Shortboard, the patch has been loaded into the Flextone II, but it is not yet saved. 

8.  Manually save the tone in the Flextone III into the desired location (not via the computer).  You can find instructions for how to do that in the Flextone III manual.


I've also powered off and on the Flextone III, repeatedly, while it is connected to Line 6 Edit and a patch is already loaded in Line 6 Edit.  I've sometimes seen the Loaded Patch name appear on the Shortboard Display, and when that happens, I save it to the Flextone III manually.


This isn't a science - it's just something that has worked for me repeatedly since I started experiencing these problems, and it's always worked, in the long run.  Sometimes, it has taken me about 30 minutes to save one patch, but as I said, at least I've gotten it to happen.  Is this a great solution, no.  But it is a solution nonetheless.


I hope this helps someone.


Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...