Jump to content
Sign in to follow this  
Axefxpwner

Relay G90 receiver super loud shrieking when pack on

Recommended Posts

Hello, wondering if any of you have had a similiar issue.

Today I fired my rig up that has been working perfectly for years, when I flipped my pack on, a super loud shrieking oscillation overloaded the input of my axe fx. All lights to red solid constantly.

Tried a different pack, same deal. Super loud distortion overloading the input.

Tried to come out of the aux output 1/4" instead of the main out 1/4". Same distortion.

Restarted unit, exercised 1/4" jacks, tried multiple cables and always the same thing.

When guitar is plugged straight into axe fx with cable it sounds normal, which is leading me to believe my relay receiver is shot as I don't believe both packs just died.

 

Has anyone else encountered this or have an idea what may be going on? I need a wireless so if anyone has insight towards how much this may cost to get serviced/how long, or if I'm better off just buying a new setup.

 

Thanks!!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...