Jump to content

Native DSP error


dbraman
 Share

Recommended Posts

I just ported everything over to my new iMac. Everything went perfectly, thanks to Time Machine, EXCEPT when I go to open Helix in Logic Pro, I get an error message saying "Failed to connect to DSP engine. Device has not been initialized properly" Anyone know what might be going on. Native is there as a plug in...I just can't get it to come up fully

Link to comment
Share on other sites

Sorry, not sure what you mean. Are talking about wifi? If so, yes, it's turned on

 

Yes, that's what I was referring to...

 

Anyway, I think the issue might be that you have to authorize your new iMac. You probably need to do a clean install of Native to do that.

Link to comment
Share on other sites

So I think I know what the cause of the problem is that License Manager doesn't recognize the new iMac; it's only seeing the old MacBook Pro that I proted everything over from (even when I tell it to scan for devices.) Not sure what to do about that. I opened up a ticket with Line6. Three days to get back to me...really?!:(

Link to comment
Share on other sites

So I think I know what the cause of the problem is that License Manager doesn't recognize the new iMac; it's only seeing the old MacBook Pro that I proted everything over from (even when I tell it to scan for devices.) Not sure what to do about that. I opened up a ticket with Line6. Three days to get back to me...really?! :(

 

The Native license isn't handled by License Manager... It's all just based on the number of authorizations on your Line 6 account.

Link to comment
Share on other sites

The Native license isn't handled by License Manager... It's all just based on the number of authorizations on your Line 6 account.

Hmm. so if it's seeing the iMac as the MacBook Pro it's already authorized, it should be ok with the iMac..I suppose? Crap, I got nothin' and no clue again

Link to comment
Share on other sites

Ok, had this same problem -

 

My Windows DAW is never online other than briefly for authos and such, I use a WiFi dongle to hit my home network.  The evening I installed Native I plugged in, shot up and got the autho  - Native fired right up, yippee!  Got home the next day, tried to open and got the exact same message as the OP.  Scratched my head a bit - what was different from last night?  AHA!  Plugged in the Wifi dongle, and Native opened right up.

 

Some discussion over at TGP brought to light that Native needs to see an active NIC, part of the autho process.  Every time I go to invoke I have to plug in my dongle, open Native - then I can unplug and go about my business.  Personally I - and others - have expressed our dislike for this behavior, but I assume it's part of the "deep code" and am not holding my breath.

Link to comment
Share on other sites

SOLVED! At the bottom left of the Native interface, there's a gear icon (for settings). Click on that and there's a dialogue for Authorization. Log into Line 6 account; deauthorize; reauthorize...and that's it. Phew, glad that's over. Loving the new iMac now

Link to comment
Share on other sites

Ok, had this same problem -

 

My Windows DAW is never online other than briefly for authos and such, I use a WiFi dongle to hit my home network. The evening I installed Native I plugged in, shot up and got the autho - Native fired right up, yippee! Got home the next day, tried to open and got the exact same message as the OP. Scratched my head a bit - what was different from last night? AHA! Plugged in the Wifi dongle, and Native opened right up.

 

Some discussion over at TGP brought to light that Native needs to see an active NIC, part of the autho process. Every time I go to invoke I have to plug in my dongle, open Native - then I can unplug and go about my business. Personally I - and others - have expressed our dislike for this behavior, but I assume it's part of the "deep code" and am not holding my breath.

Turning networking off is often recommended for serious DAW use, to cut down on background tasks, but it sounds like you can't when you first start Native.

 

Software authorization is a hard problem. It's a constant battle between pirates and developers. One of the key pieces of such tech is some means of uniquely identifying each computer, and NIC cards are often part of that, since they have supposedly unique MAC addresses. So as usual, it's honest customers who get inconvenienced, while pirates and their "customers" have their way with it anyway.

 

This is NOT a dig at Line 6. Hard problem, they do the best the can, like all devs.

Link to comment
Share on other sites

Turning networking off is often recommended for serious DAW use, to cut down on background tasks, but it sounds like you can't when you first start Native.

 

Software authorization is a hard problem. It's a constant battle between pirates and developers. One of the key pieces of such tech is some means of uniquely identifying each computer, and NIC cards are often part of that, since they have supposedly unique MAC addresses. So as usual, it's honest customers who get inconvenienced, while pirates and their "customers" have their way with it anyway.

 

This is NOT a dig at Line 6. Hard problem, they do the best the can, like all devs.

Agreed - I'm not slamming on L6.  At best it's a minor annoyance, I would have a real problem if I had to KEEP the DAW online, but I can live with the momentary use of the wifi dongle when I start up.  Guess I'm a bit surprised that they didn't seem to realize many DAW users prefer to have no connection, and hence no active adaptor.

 

As noted a number of folks have weighed in on this, it is a little pita - but I'm not expecting a change anytime soon, if at all.

 

Hey - I've got freaking Helix in my DAW!  The Bear is Dancing....

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...