Jump to content
fremen

Channel switching a EVH 5150 III15W LBXII

Recommended Posts

Wondering if anyone uses such an amp with the Helix ? Unlike its bigger brothers, it's a two channel amp, with a simple footswitch, using a mono jack. I assumed channel switching by the Helix would work but it's not ; as soon as I plug in the cable, it goes to the blue channel. With the cable unplugged it's either the blue or the green. Anyone has an idea ?

 

Cheers,

 

Fremen

Share this post


Link to post
Share on other sites

Wondering if anyone uses such an amp with the Helix ? Unlike its bigger brothers, it's a two channel amp, with a simple footswitch, using a mono jack. I assumed channel switching by the Helix would work but it's not ; as soon as I plug in the cable, it goes to the blue channel. With the cable unplugged it's either the blue or the green. Anyone has an idea ?

 

Cheers,

 

Fremen

 

Have you played with the three EXT AMP settings in Control Center? I think they are tip/sleeve, ring/sleeve, or both. 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...