Please ensure Javascript is enabled for purposes of website accessibility Jump to content

JTV69 Model Selector Switch not working with Helix 2.30

Recommended Posts

I have a very strange problem that has surfaced after the Helix 2.30 upgrade.


And everything worked with the last version of firmware which was version 2.21.


I have a JTV69 at firmware revision 2.22, Helix Floor now at 2.30, and the new 2.30 HX Editor. The Helix upgrade to Version 2.30 worked fine without a hitch.


But now the 5-position model selector switch no longer changes guitar models on my JTV69.


Interestingly - the bank select knob works. But not the 5 position switch. If I am at preset 1-3 on the Variax and change banks - I get preset 2-3 correctly for example.


But trying to use the 5-position switch inside a bank does not work.


This all happens when using the JTV connected to the Helix with the VDI cable


SO ---- to make surety JTV was ok


I tested the guitar with my old HD500 - everything works fine. Using the same VDI cable

Tested the guitar with my Firehawk  floor board. Using the same VDI cable - everything worked fine

I put a battery in the guitar and connected with an old tech guitar cable - everything works fine.


I have concluded from this that the JTV is fine.


Also - if I start Workbench HD or the HX editor or both - I can force model changes on the guitar connected with VDI to the Helix by double clicking on the model in Workbench HD or changing it in the HX editor input block.


Not sure what to make of it all. I have filed a support ticket. Has anyone else seen this? Or is it just my rig.


Would love to hear from anyone or especially Line 6 - I am baffled and at a total loss as it all worked perfectly with Helix 2.21

Link to comment
Share on other sites

I do have the JTV 69 and updated the Helix floor to 2.30 without noticing any problems other than the old Edit did not uninstall and the update did not show the new factory preset... not until I restored the Helix by holding buttons 9 and 10 together while switching the Helix on.


So far the JTV is working as it did before the update.


If you try to update again, make sure that you have only the very basic/least USB devices connected to your computer, to minimise possible problems, that include the disconnection of the guitar from their HELIX.


Hope you get your problem resolved.

Link to comment
Share on other sites

See the same post on the Helix Forum


Two forum members solved my problem


Set the Variax setting in the Variax parameters block in the HX Editor to PER PRESET - everything works again


Could not find a way to do it directly on the Helix Floor but was able to fix using the editor

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...