Please ensure Javascript is enabled for purposes of website accessibility Jump to content

Firmware update problem


Recommended Posts

I just bought new AMPLIFI 150 today and tried to update the firmware.

- Download Line6 updater and 2.6 flash,

- Connect the USB cable

- Run the updater but the updater show "Select device to update" 


What am I doing wrong?  Please help.



Link to comment
Share on other sites

Are these new units, or did you both buy them used? If they're new, you might expect that the firmware would already be at 2.6. Are you able to confirm that it is not?


This is a touchy area. I bought a used 150 that came with version 2.5, and I wanted to update it, as well as reverting to the factory default presets. It failed spectacularly, even when trying to do it while a Line 6 tech talked me through repeated attempts on the phone. I'm very knowledgeable computer & hardware guy, and tried it with 3 separate desktops. It left me without a functioning amp, which had to be sent back to the factory to take care of it. Line 6 was gracious enough to make the upgrade at no charge, but it cost me over $110 to ship it to them. That sucked the heck out of the good buy that I got in selecting a used device...


Unfortunately, this doesn't seem to be an anomaly -- there are quite a few reports about this scenario on the net, and here in the forum. If your amp is brand new from the store, you may have some options, up to and including returning it for a refund. Or you may be able to have it repaired under warranty. Just be aware that it's not unheard of for these things to get bricked when attempting an update, EVEN IF YOU KNOW WHAT YOU ARE DOING AND FOLLOW THE PRESCRIBED STEPS TO THE LETTER.


It's troubling that firmware upgrades appear problematic with these things, but that's the way it seems. Be aware of your options before jumping in, just in case something goes wrong. I kinda doubt that there will be future firmware changes, and I'll be very wary about attempting an update, should one come along.

Link to comment
Share on other sites

"So I tried the Bluetooth option, which took 45 minutes, but was ultimately successful...."


Seems to me that I also updated my 30 via Bluetooth when I first got it. But when it came to doing it with the 150, I tried USB, which failed quite spectacularly and repeatedly. If they ever come out with another update, gonna give it a lot of thought before attempting anything. I can handle 45 minutes or an hour. Beats spending over $100 for shipping and being without the amp for 3 weeks...

  • Downvote 1
Link to comment
Share on other sites

  • 2 weeks later...

FWIW. I just got an Amplifi 30, and it would not update to 2.6 over Win 10, even using different computers (over my Wi-Fi LAN).

So I tried the Bluetooth option, which took 45 minutes, but was ultimately successful....

Same here, with the PC Laptop I got no/ frustrating results, then with my iPhone 6 it worked brilliant, just timeconsuming.

Link to comment
Share on other sites

  • 1 month later...

Same here, new out of the box Amplifi75.  Tried updating using Macbook pro running 10.13.3 and Line 6 updater ver1.12 update failed. 


Tried downloading ToneMatch_v2_60_0.tmf and doing a local file update, failed again. 


iPad/bluetooth route seems to be working it's about 50% done after 20 minutes.

Link to comment
Share on other sites

  • 3 weeks later...

I’m looking to see if it’s a windows 10 issue though, mainly because over half my gear no longer works in windows thanks to its “creators update†and all the other ones. I suspect line 6 aren’t at fault here and it might just be windows.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...