Jump to content

Helix Native 1.10 in Logic Pro X: "Device has not been initialized properly"


bradblyth
 Share

Recommended Posts

Cant use Helix Native 1.10 in Logic Pro X 10.3.3. Here are the details:

 

1. Had no issue with prior Helix Native software operating in my Logic Pro X Daw 10.3.3;

2. Downloaded and installed Helix Native 1.10;

3. Opened Logic Pro X session audio track and clicked on Audio FX "Helix Native". Got the authorization screen, authorized this computer and got the "You have a valid Helix Native license that does not expire". But, above the message in bright red letters is: "Plugin Not Initialized" and it won't open or load sounds;

4. Went to the Plug In Manager within Logic Pro X and Helix 1.10 is authorized, successful, and checked; 

5. Removed instance of Helix from the track and reloaded Helix...get an orange bar across the top of the Helix interface stating "Failed to connect to device. "Device has not been initialized property. [Code -8201); and

6. Tried re-downloading and got the same thing. Did not actually remove Helix and re-download...just downloaded again. 

VERY FRUSTRATING. Any tips would be helpful...did I miss something?

Thanks!!

Link to comment
Share on other sites

I can’t even get sound with Helix Native on Logic Pro X. I’ve moved in the past year to Studio One 3 and have it working perfectly with that DAW. I had no problem initializing it in Logic and it comes up and works but no sound.

 

Hope you are able to solve it!

Link to comment
Share on other sites

  • 3 months later...

Not sure what's up, but that's got to be frustrating. Did you open a ticket? I usually hear back within one day on support stuff.

 

You could try de-authorizing and then authorizing. https://line6.com/account/devices/

 

Line 6 also makes this mention:  "Helix Native requires an internet connection to initially authorize the license both for the demo and full versions. Once the license has been authorized, you no longer need an internet connection to use the software. But, because of how the authorization works, you do need an NIC (Network Interface Controller) enabled. Do not disable your network card (wireless or LAN) when running Helix Native. If you want run without an internet connection, just unplug your LAN cable or disconnect from your WiFi network."

 

 

Link to comment
Share on other sites

  • 11 months later...

Go to preferences > audio > Input device

Make sure that the Input device is not Helix.

I changed it to "system setting" and it loads fine now.

Macbook Pro 13, 2017 macOS Mojave version 10.14.4

 

I hope this helps. \m/

Link to comment
Share on other sites

On 4/3/2019 at 6:29 AM, Sigkill9 said:

Go to preferences > audio > Input device

Make sure that the Input device is not Helix.

I changed it to "system setting" and it loads fine now.

Macbook Pro 13, 2017 macOS Mojave version 10.14.4

 

I hope this helps. \m/

 

Hi sigkill9,

 

Just to make sure that I fully understand your comment above.
Did you have a hardware Helix connected to your MacBook Pro when you changed the Preferences > Audio > Input Device > System Setting ? 

I don't understand how or why that works, but if you say it does - excellent, that's good to know.
After Native has initialised is it possible to switch back to the previous Audio configuration without screwing things up again?

 

Lucky for me that my version of Native works as it should, because I use my Helix Floor unit as the audio interface for recording and re-amping and I need to have the Helix designated as the Input Device.

Link to comment
Share on other sites

@soundog, @datacom

 

Apologies, I didn't see these questions.

This is a brand new machine and I have never hooked the hardware Helix up to it.

I think maybe I had used hardware Helix when recording the song and saved the settings in the LPX file.

That is maybe why it was available as a choice.

I wish I would have taken a screenshot before changing the setting as it was no longer a choice once I changed it.

 

No hardware helix attached when setting preferences.

 

I'll watch this thread if you have anymore questions.

 

thanks,

 

  • Thanks 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...