Jump to content

Roland JC-40 Reverb Switching through Amp out.- How?


Psycho_Dog
 Share

Recommended Posts

Hi Guys. I am a first time Helix LT user and having a lot of fun (and a few frustrations) in getting the Helix fully set up. I would really like to have the helix

control the Reverb on my new Roland JC-40 amp, but haven't had any luck so far. I have gone through all of the settings and tried the command centre etc etc.

When I plug my fender reverb / vibrato 2 switch pedal in to the amp, the vibe switch turns the reverb on/off per each click. When I plug a cable (1/4 guitar or TRS) into the ext. amp out on the Helix and into the reverb switch in on the amp, all I get is hum. What am I doing wrong here?? The Helix manual is useless. The JC40 manual says I can use Boss FS-5L footswitch (latch type switches) if that gives any clues, but obviously I would like to do this switching through the Helix it would be magic!  

 

If someone can assist or point me in the right direction that would be a great help. I have done a few searches here and have turned up nothing I could use at this early stage. Thanks.

Link to comment
Share on other sites

  • 2 months later...
On 1/2/2018 at 3:55 PM, Psycho_Dog said:

Hi Guys. I am a first time Helix LT user and having a lot of fun (and a few frustrations) in getting the Helix fully set up. I would really like to have the helix

control the Reverb on my new Roland JC-40 amp, but haven't had any luck so far. I have gone through all of the settings and tried the command centre etc etc.

When I plug my fender reverb / vibrato 2 switch pedal in to the amp, the vibe switch turns the reverb on/off per each click. When I plug a cable (1/4 guitar or TRS) into the ext. amp out on the Helix and into the reverb switch in on the amp, all I get is hum. What am I doing wrong here?? The Helix manual is useless. The JC40 manual says I can use Boss FS-5L footswitch (latch type switches) if that gives any clues, but obviously I would like to do this switching through the Helix it would be magic!  

 

If someone can assist or point me in the right direction that would be a great help. I have done a few searches here and have turned up nothing I could use at this early stage. Thanks.

     YEP,   same here, but with a Fender Blues Deville Reissue. Out the Helix EXT AMP jack into the channel switching jack on the amplifier, all I get is a hum. Tried standard mono guitar cable, then an TRS cable, then even a Boss FS-5U pedal and nadda. But I plug in a cheap little round footswitch with an attached cable and it works great. Sure would be awesome if my Helix floor could switch my amp channels. Oh and yes I updated to firmware version 2.53. No change. No switching, just loud hum.

Link to comment
Share on other sites

  • 2 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...