Jump to content
Lmbull

Micro spider sounds like an 8 bit video game.

Recommended Posts

I bought a used micro spider on eBay and it sounds horrible. What would cause the amp to sound like an 8 bit midi?

Share this post


Link to post
Share on other sites

Reset didn't help. I don't expect much other than to sound like a guitar. It sounds horrible. I uploaded a video to youtube. I've tried it with the XVive U2 wireless system then a 10' cable same result with both. It doesn't matter what's plugged in the sound sucks.

https://youtu.be/nutpJ8U0t4A

Share this post


Link to post
Share on other sites

What is that plugged into the input?

What ever it is, it's probably what's making it sound like that.

Share this post


Link to post
Share on other sites

Definitely odd.

All the Micro Spider amps I've worked on here, I've never heard that.

 

Share this post


Link to post
Share on other sites

There's not much to the amp so I would think it's safe to assume that replacing the mainboard would fix it.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...