Jump to content
Sign in to follow this  
merlosw0

Helix Edit 2.51 and Line 6 updater 1.12 not opening using Os Mavericks

Recommended Posts

I already uninstall and reinstall the line 6 updater and the HX edit 2.51 and both of them crash when i try to open them. 

 

went back to HX edit 2.30 and Line 6 updater 1.11 and they open just fine but they don't have the updated effects.

 

Any one else having this issue? 

 

Please help

  • Upvote 1

Share this post


Link to post
Share on other sites

Did you also update the driver as part of the HX Edit 2.51 installation?

Share this post


Link to post
Share on other sites

You can't have both applications running at the same time when you're connected to your Helix.  The device can only communicate with one application at a time.  Exit out of all applications (including Logic Pro, MainStage, etc.) and run the Line 6 Updater by itself.  It should work for you then.

Share this post


Link to post
Share on other sites

I believe the problem is trying the update on OS 10.9.5.  Unfortunately, I can't update to High Sierra.  

Share this post


Link to post
Share on other sites

The latest Mac driver for Helix is v1.04. It is listed as being compatible with OSX and forward.

 

It also includes this notice:

 

IMPORTANT! Installing the Helix Mac Driver 1.0.4 precludes using Helix with the class-compliant OS X Core Audio driver.

 

Note that macOS High Sierra 10.13 has implemented a change to how drivers are accessed that may require your attention. If you cannot use your Line 6 device after installing this driver, please see this article: macOS High Sierra 10.13 Driver Installation Change

Share this post


Link to post
Share on other sites

I've been working on this for the last 4 hours without luck ;-( 

 

can some please help  :unsure:

Share this post


Link to post
Share on other sites

I am using Mountain Lion and Edit 2.51 does not work for me.  The firmware 2.5 is there but the edit will not work.  I noticed on the edit down load page that Mavericks and Mountain Lion are no longer supported.  I can't update past Mountain Lion as I'm using PT10.  Hope we're not SOL.  I think I will try the Mac download and hope that works.  Worst case would be at 2.50  with the 2.30 editor.  

Share this post


Link to post
Share on other sites

Yesterday, when I downloaded the file Mavericks was supported, I guess they updated the download page. :( 
That is weaksauce on Line 6's part because 2.3 works just fine.  

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×