Jump to content
Joshuaconrey

HX Edit Won't Open

Recommended Posts

Hi folks;

   First time posting on the forums, and I'm hoping you all can help me out. I just successfully updated to firmware 2.50 for Helix (which is everything I hoped it would be :D ), and I'm trying to use HX Edit. I downloaded it successfully, but when I click on the application icon to open it, it starts to open the black window, then immediately shuts down with the message "HX Edit quit unexpectedly." I've tried deleting and re-downloading with the same result. I opened the app directly from the 'Applications' folder, not from a shortcut.

 

   I'm running a Mac with OS X 10.8.5, and haven't had any trouble with Line 6 or Helix software heretofore. This was the first version of 'HX Edit' that I've installed. Prior to this I was using the old 'Helix' app (which I've already deleted). I'm not worried about restoring any preset or IR backups, I just want the app to open and work properly. Any tips or solutions to this problem would be greatly appreciated!

 

Thanks!

 

 

 

 

 

[Moderators, if there is an existing topic on this issue, feel free to move my post there. This is my first time posting and I don't know how all of this works just yet.]

Share this post


Link to post
Share on other sites

This may not be the issue, but you are running a very old version of OSX - came out in 2012 (10.8.5 maybe 2013)................I'm assuming there is some software that is keeping you to that old OS?

I would think you need to update for all kinds of reasons?  Even internet/web stuff must be giving you trouble?

Share this post


Link to post
Share on other sites

I just don't like the look and feel of the newer versions. Feels less well-thought-out. Kind of cheap looking to my eye. No major problems so far running the older OS, except this one. Under the OS listings at the bottom of the update post, it does list Mac OS X as compatible with the update, so I'm assuming that the OS isn't the issue.

Share this post


Link to post
Share on other sites

Your issue sounds different, but just to check, is the Helix device completely turned on before you launch HX Edit.  Unfortunately, and unlike HD Edit,  HX Edit won't function unless the device is connected and turned on.

Share this post


Link to post
Share on other sites

Hi folks;

   First time posting on the forums, and I'm hoping you all can help me out. I just successfully updated to firmware 2.50 for Helix (which is everything I hoped it would be :D ), and I'm trying to use HX Edit. I downloaded it successfully, but when I click on the application icon to open it, it starts to open the black window, then immediately shuts down with the message "HX Edit quit unexpectedly." I've tried deleting and re-downloading with the same result. I opened the app directly from the 'Applications' folder, not from a shortcut.

 

   I'm running a Mac with OS X 10.8.5, and haven't had any trouble with Line 6 or Helix software heretofore. This was the first version of 'HX Edit' that I've installed. Prior to this I was using the old 'Helix' app (which I've already deleted). I'm not worried about restoring any preset or IR backups, I just want the app to open and work properly. Any tips or solutions to this problem would be greatly appreciated!

 

Thanks!

 

 

 

 

 

[Moderators, if there is an existing topic on this issue, feel free to move my post there. This is my first time posting and I don't know how all of this works just yet.]

 

I think the issue may be your older version of OS X as it sounds like you have already upgraded to the 2.51 version of HX Edit. There may be a good chance that the problem you are running into is indeed related to your older Mac build(10.8.5) of OS X. The notes in the 2.50 release topic from DI say that 10.9 (Mavericks) is no longer supported. That would seem to imply that earlier versions of the OS like 10.8.5(Mountain Lion) might find themselves unsupported as well. In my experience "unsupported" does not necessarily imply that every piece of hardware running that OS flat out won't work but unfortunately there is a much higher chance that your OS version is incompatible. The best advice would probably be to upgrade your OS or use a different computer like a PC running Windows 10 with the Helix. Not ideal I know given your dislike of later OS X versions but either option(upgrade OS X or use alternate computer) probably means less headaches going forward.

Scroll down to release comments: http://line6.com/support/topic/18284-latest-helix-firmware-250—out-now/?p=135735

 

Quote from Line6's topic on the 2.5 release:

  • Mac OSX 10.9 (Mavericks) is no longer supported

Share this post


Link to post
Share on other sites

 

I think the issue may be your older version of OS X as it sounds like you have already upgraded to the 2.51 version of HX Edit. There may be a good chance that the problem you are running into is indeed related to your older Mac build(10.8.5) of OS X. The notes in the 2.50 release topic from DI say that 10.9 (Mavericks) is no longer supported. That would seem to imply that earlier versions of the OS like 10.8.5(Mountain Lion) might find themselves unsupported as well. In my experience "unsupported" does not necessarily imply that every piece of hardware running that OS flat out won't work but unfortunately there is a much higher chance that your OS version is incompatible. The best advice would probably be to upgrade your OS or use a different computer like a PC running Windows 10 with the Helix. Not ideal I know given your dislike of later OS X versions but either option(upgrade OS X or use alternate computer) probably means less headaches going forward.

Scroll down to release comments: http://line6.com/support/topic/18284-latest-helix-firmware-250—out-now/?p=135735

 

Quote from Line6's topic on the 2.5 release:

  • Mac OSX 10.9 (Mavericks) is no longer supported

 

 

Upgrading is free via the Mac Store.  Just sayin'.  :)

Share this post


Link to post
Share on other sites

Hi,

 

I just got my Helix, updated it to 2.7.1 and installed the latest HX Edit-version.

When installing the 2.7.1 firmware, it updates properly, however it does not automatically reboot as the updater says it will. So I power it off after a few minutes and when it starts up it rebuilds the presets as it should.

When I try to start up the HX Edit software it finds the device (Helix Floor) and then immediately closes.

 

I spoke once with support over the phone and they told me to reset after I re-installed the firmware, but it didnt work.

Also I tried reinstalling the HX Edit software.

 

EDIT: tried on my MAC and it works. Windows version does not. Also, did yet another firmware-update and it still does not manage to reboot the Helix automatically.

I hope somone at Line6 sees this so they can improve the software, because this was rather disappointing.

Share this post


Link to post
Share on other sites
1 hour ago, Borgelin79 said:

Hi,

 

I just got my Helix, updated it to 2.7.1 and installed the latest HX Edit-version.

When installing the 2.7.1 firmware, it updates properly, however it does not automatically reboot as the updater says it will. So I power it off after a few minutes and when it starts up it rebuilds the presets as it should.

When I try to start up the HX Edit software it finds the device (Helix Floor) and then immediately closes.

 

I spoke once with support over the phone and they told me to reset after I re-installed the firmware, but it didnt work.

Also I tried reinstalling the HX Edit software.

 

EDIT: tried on my MAC and it works. Windows version does not. Also, did yet another firmware-update and it still does not manage to reboot the Helix automatically.

I hope somone at Line6 sees this so they can improve the software, because this was rather disappointing.

 

Everything you say suggests the problem lies in the HX Edit program having a version incompatibility problem with the Helix firmware which causes it to shut down.  When you said you installed the HX Edit, you do understand that to install the HX Edit program you have to download the HX Edit install program, then run the file you downloaded in order to actually install the HX Edit program.  Another common problem is if you choose to not have the install program replace the HX Edit icon on your desktop  you may actually be running an older version of HX Edit and not the newly installed version.  None of this explains the lack of automatic restart however unless you didn't actually RUN the HX Edit installation program in which case you would be executing an older and possibly incompatible version of the Line 6 Updater which gets installed when you run the HX Edit installation program.  If I were you I'd go through the COMPLETE installation process as defined in the release notes which is to download and RUN the HX Edit install program, then run the Line 6 Updater program and update the firmware.  If you do that and follow it to the letter I think you then may have evidence there may be a problem with your unit and you need to get Line 6 to physically look at it.

 

As far as improving the install program, I think the VAST majority of users have no problems with the update process.  Only a very small handful of people tend to have problems.  Most of which are from not reading and following the installation process completely.  I don't think Line 6 can do anything about that one.

Share this post


Link to post
Share on other sites
18 hours ago, DunedinDragon said:

 

Everything you say suggests the problem lies in the HX Edit program having a version incompatibility problem with the Helix firmware which causes it to shut down.  When you said you installed the HX Edit, you do understand that to install the HX Edit program you have to download the HX Edit install program, then run the file you downloaded in order to actually install the HX Edit program.  Another common problem is if you choose to not have the install program replace the HX Edit icon on your desktop  you may actually be running an older version of HX Edit and not the newly installed version.  None of this explains the lack of automatic restart however unless you didn't actually RUN the HX Edit installation program in which case you would be executing an older and possibly incompatible version of the Line 6 Updater which gets installed when you run the HX Edit installation program.  If I were you I'd go through the COMPLETE installation process as defined in the release notes which is to download and RUN the HX Edit install program, then run the Line 6 Updater program and update the firmware.  If you do that and follow it to the letter I think you then may have evidence there may be a problem with your unit and you need to get Line 6 to physically look at it.

 

As far as improving the install program, I think the VAST majority of users have no problems with the update process.  Only a very small handful of people tend to have problems.  Most of which are from not reading and following the installation process completely.  I don't think Line 6 can do anything about that one.

 

 

Hi and thanks for your reply.

 

Your explanation and suggestions would probably help someone who's completely IT-illiterate, however I have more than 30 years of experience with advanced computer-systems, both software and hardware, and following the procedure for updating the Helix is child's play.

 

I have of course the latest versions of all the necessary software:

- Updater 1.16

- HX Edit 2.7.1

- Firmware 2.7.1

- Driver 2 1.91

 

As already mentioned I tried reinstalling software and re-flashing the Helix.

 

I have no issues with my Windows-machine, all other software runs fine, except for HX Edit.

 

My hardware is as follows:

i7 8086 (not overclocked yet)

ASUS ROG Strix Z390-F

32 GB RAM

MSI 980Ti

 

 

Share this post


Link to post
Share on other sites

HX Edit doesnt start on my win 10 64bit  i7 4790k 4ghz 16gb ram. tried it with my helix on and off. Please Support;-)

Share this post


Link to post
Share on other sites

Same problem since update to 2.80. No problem with HX Edit 2.70.

Please, help!

Share this post


Link to post
Share on other sites

To the OP, likely as others have said it's probably your release of OSX. I feel your pain, I have a 2007 intel iMac, running Lion 10.7.5. This is the LAST version of OSX that can run on my hardware.  I tried to load HX Edit and it installed, but when executing the app, it said my release was too old. 

For those that say "upgrade OSX", easier said than done. Like I said, I cannot unless I upgrade my MAC unless the hw gets upgraded. Which then would make me have to upgrade ProTools, which then would make my Avid 003 a paper weight as it uses the old Fire Wire connection, which would also make my old Waves Bundle and all the other old plug-in software inoperable. I work in technology as an engineer and fully understand hardware/software life cycles.  You see, it's a domino effect. 

 

So as others have said, if you're using your stomp to connect to a DAW on your old mac, it will work... Even my ProTools 10 recognized the HX Stomp via USB. Sad part is I can't hear it because the driver doesn't play with ProTools Audio Aggregate.  So old fashion way, L/R  TRS out of Stomp into my 003, and use a Windows 10 Laptop for HX Edit. 

 

 

 

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×