Jump to content
arch23

Weird foot switch problem

Recommended Posts

Hi,

I have this weird foot switch problem - 

My stomps are set to show 4 patches at the top row and 4 snapshots at the bottom row. Every stop on footswitch 4 in the top row always switches to the assigned patch.
In Stomp Footswitch Mode I usually assign the delay to foot switch number 4. Very often when I stomp footswitch 4 to activate to bypass the delay it does not work or switch momentarily until I lift my foot off. I have to stomp it several time to take effect and sometimes in does work in the first try. Again - this happens only in Stomp Footswitch Mode.

Is it a faulty switch? Whats going on here?

Thanks

Ori

Share this post


Link to post
Share on other sites

I have the same problem in that switch!! And some times it happen me in tempo switch.

i am in Mazatlan Mexico and i cant send it to United State to fix it.

 

Share this post


Link to post
Share on other sites

It's a contact problem in the switch. I had the same issue with another switch. I opened my Helix. There are little micro switches under the foot switches. I used a little bit contact cleaner spray on it. Now everything is fine.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...