Jump to content
themetallikid

Expression pedals......what you use and why?

Recommended Posts

So...what you using and more specifically....what issues have you had with them?  Any short comings you have to compensate for? 

 

Strange questions I know.....but I do not like to tolerate the issues I've had so far with my Mission Engineering pedals (no issues when used with my GT100 or Fractal units previously) or the onboard expression pedal. 

 

I'd be willing to sell my ME Pedals to fund one that will be consistent....

 

What you got?....Or what have you used that you stopped using, lol.

Share this post


Link to post
Share on other sites

Two cheap plastic Line 6 EXP-1 pedals, one of them is more than 3 years old. ZERO issues, and are very durable even though they are plastic. $50 each new. I weigh 200lbs+ and put my full standing weight on them when I use them, no mechanical issues. I can get almost three of them for the price of the Mission pedals that all the cool kids have. 

Share this post


Link to post
Share on other sites

I'll look into those...I like the build quality of the ME's, and the standard Crybaby type enclosure.  Usually I've found other pedals to have too short of travel.  I really liked the Ernie Ball Exp pedals, but who in the hell uses a string to move a pot in 2018?  I had it 6 months and string broke....

Share this post


Link to post
Share on other sites

Are you using the ME pedal specifically made for L6 products? Or the generic one?

Share this post


Link to post
Share on other sites

I’m using the same two Line 6 MIssion Engineering pedals I used for years with my Line 6 M13. No problems at all with those.

Share this post


Link to post
Share on other sites

It's just the standard ME Pedal   https://missionengineering.com/shop-2/products/expression/multi-use-exp/ep-1/?v=7516fd43adaa   I've had it for years and no issues with it working with my previous units.  Is there something special that L6 products should react differently?  If thats the case then why does the on board one not work consistently either?  

 

i will look into the L6 ones, but confused on why the ME ones wouldnt be working?  I'm using a standard patch cable like I always have...I know the Ernie Ball ones require a specific tip/ring/sleeve thingy (technical I know, lol)....but these never seem to have, and they dont behave like the ones do that do get the wrong type of cable. 

Share this post


Link to post
Share on other sites

I use Mission pedals because they work well after steppin all over them for over 2 years now. Tuff rugged resilient pedals, or you might like the plastic kind the cool kids have.... ; )

Share this post


Link to post
Share on other sites

Ernie ball VP Jr 25k. Hauled it to gigs for years, and it's never failed. Love the long draw on it for whammy and volume swells. Not ideal for wah, but I hardly ever use that. 

Share this post


Link to post
Share on other sites
9 hours ago, themetallikid said:

... then why does the on board one not work consistently either?  ...

 

 

What Helix do you have? I have the Floor model and have had zero issues with the on board pedal. Very robust. If you are having issues with the on board, then open a support ticket. There are some LT's that have broken mechanically at the pivot point. 

Share this post


Link to post
Share on other sites

I'm using a modded crybaby. I replaced the pot in it and also spring loaded it. It's been working flawlessly for wah and pitch effects.

 

The onboard pedal of my LT works fine unless I use the toe switch in it. When I do use the toe switch it seems to mis-calibrate and the forward pitch only goes to 97-98%. So I only use it to blend and mix certain effects.

Share this post


Link to post
Share on other sites

I got the Mission Engineering Inc EP1-L6 Expression Pedal when Line 6 was selling them for $45 I think it was. Not worth the full price since the aforementioned Line 6 Exp pedal, which I have had longer, is available. Love the Mission Engineering one but DANG! The full price is a bit much for me. I am surprised that you've had issues. Is it an "official" made for Line 6 pedal or just a "generic" one I wonder. I think the pot is supposed to be 10K. Could that be the issue?

Share this post


Link to post
Share on other sites

Well the ME one I have is just the standard regular one...nothing specific to any unit or anything else. 

 

Is the L6 one on the L6 website compatible with the Helix LT, it didn't list it on the website that I saw.  I see that ME has a L6 version, but for $130...I'd hope there were other options available..but I'll go there if I have to.

 

The On board pedal doesn't have a 'mechanical' issue like others have offered.  Here is what happened...I decided since I only use one expression pedal per preset (mostly) I could just use the on board one and utilize the switch if I needed a 2nd one.  I went through my presets updated to using the onboard pedal.  Got all of the auto-engages set I believe to 98% to engage the effect.  That gave me a little extra room at the top.  My first gig was an abbreviated setlist night, first preset that needed something to be controlled was Crazy Train...pulled up the preset (which worked flawlessly on the 15-20 presets I changed that week) and we got 30 seconds into the song...something didn't sound right.  I check my tuning, I'm all good....other guitar checks his tuning....all good.   I stop the song so we can identify the problem...this is 6 songs into the night, so not something that was there previously....we each play an open E string and I can hear its my guitar that's out of tune...quickly check my preset in the Helix, and my Whammy/Pitch Effect is engaged...I move the pedal to let it reset itself and disengage the effect when passing 98%, but I notice that its only reading 0-91%.  So from that point on in the show, any preset that had a expression controlled effect needed to have the bypass adjusted (why would I trust the number I'm adjusting it to at this point) or have the effect removed and resave the preset. 

 

^^^ this is unacceptable...I've experienced the same with the ME-EP1 pedal, but its not been as drastic only dipping down to the 96%+ ranges...but as soon as I set it it changes how it reads it....if it was 96% consistently then that's an easy adjustment...but if it reads 96% at full...and I adjust the auto-engage to turn on at 95%...and the next time its reading at 100% or 99% when fully toe down, I've now lost that bit of travel in the pedal...

 

 

So...I'm all for swapping pedals if I need to...just want to make sure when I go through the process of selling gear and purchasing new stuff, it will resolve this problem....as the onboard one has the same issue. 

Share this post


Link to post
Share on other sites

I am looking at the Line6 specific one with the spring effect on it.  Hopefully, that doesn't have any issues.  At that price it better not.    I haven't had any issues with the Helix Flor onboard Expression, but do not like the feel of it for a Wah or Whammy effect at all. 

 

I wonder what is different special between all of their units?  Back in the day an expression pedal was an expression pedal as long as it had the right pot in it.

Share this post


Link to post
Share on other sites

I use on 30 years old Boss stereo keyboard pedal and one new ehx expression pedal. Both works perfect. I used a BOSS FV-500 H on my POD 500X. But it does not work with the Helix floor.

Share this post


Link to post
Share on other sites

Didn't care for the feel of the Mission Engineering - didn't feel real for some reason. Couldn't use it for the wah or pitch shifting with the HX. 

Share this post


Link to post
Share on other sites

The SP1-L6 Helix pedal is what I use for the wah. The one with the switch. I adjusted the nuts on the switch so that it has a light touch when pressed and it works GREAT for me. I know that there is now a "heel down wah off" software setting but because I own the "switched" version of the Missin pedal I never tried it. Stubborn that way I guess... ; )

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...