Jump to content

Recommended Posts

Have just bought a JTV 59 and wanted to download the workbench HD to my MacBook running OS 10.13.4 High Sierra. However, the installer will not install the programme to my hard disk claiming that it needs OS 10.5 or higher???? Is 10.13.4 not higher than 10.5? Please can anybody help solving this problem

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×