Jump to content
Sign in to follow this  
PaulWilliamson

Where Was Your Helix Set On First Ever Turn On ?

Recommended Posts

Hi Everyone

 

I opened the box on a brand new Helix Floor today, it was in a plastic bag,

but the white paper warning seal that says once you open this you agree to Line 6 terms & conditions may have been re-stuck onto the polythene.

 

I was surprised to find that as soon as I plugged a power cord in, it fired up on pre-set

FACTORY 2  Rhythm Sandman..  The power switch was in the on position ? 

It looks fine no visible issues, but I just would like to know if any one else got a brand new unit that had the power switch on

and was set at some random FACTORY pre-set.

 

Works fine.. already tried a few different ways to hook it up, best I've found

so far is in Stereo split between the returns of an old Flextone Amp, and a Fishman Loudbox ..

the tweeter can be controlled on the loudbox to balance just enough treble

detail with the midrange to give very convincing Amp tones.. I started by just getting the amp models to sound as real as possible.

 

I'm old.. I've heard quite a few .. once you get the basic tone of one about right, ( with both H/B & S/C pickups ) you know your in the ball park.

Anyway.. I ramble .. :)  ..  I hope someone can remember if their new Helix was turned on when they got it, just to put my mind at ease :)

 

Regards 

Paul

Share this post


Link to post
Share on other sites

What you describe is unusual but since it's working properly I wouldn't be concerned. It's not uncommon for some retailers to update the device firmware after receiving the equipment and before selling it.

Share this post


Link to post
Share on other sites

I cant fault it as far as condition is concerned, but theres been absolutely no new electrics smell.. most gear has a new smell lol..

 

Dear Mr Dealer,

I'm returning this perfectly presented article as it doesn't smell quite like a new one should !

 

It needed updating.. I think it was still on 2.21 before  updated it. and it froze half way through the update asking to be re-booted.. 

I had already downloaded the latest firmware so I just updated it from that and it was fine.

 

In a way that makes me feel better, If it had been sent out and returned, it probably would have been updated to a more recent firmware.

 

I don't remember my PodXTLive sounding this good without quite a bit more tinkering. :)

 

Share this post


Link to post
Share on other sites

So long as you succeeded to update it to the latest firmware 2.54, you should be good to go. You may want to do the Factory Reset and Preset Rebuild: PowerOn+ FS9+FS10 routine to be sure that all the Factory Presets are present on your unit. To be sure, you should register the unit with Line 6 to be sure that the Serial Number has not already been registered. If you have any further problems, your dealer will handle it or you'll be covered by Line 6.

 

For what it is worth, when I got my new Helix Floor the entire unit box and interior bag were sealed. The Variax jack's rubber cap was loose in the bag. The power switch was in the OFF position. When powered up the Preset was Factory Setlist 1; Preset 1A. The unit had an older version of firmware. It now has fw 2.53.

Share this post


Link to post
Share on other sites

Sounds to me like you had one that had been opened and played on at the store.

Share this post


Link to post
Share on other sites

Well looking at the position of the power switch on the Helix, if the box had taken a sudden drop, the foam could deform to absorb impact but push the switch into the on position.

I checked this by re fitting it back in the two foam inserts, if you push in the right place it activates the switch.

 

That wouldn't explain why it was on Factory Pre-set 2 Rhythm Sandman though.

 

All pre-sets are as they should be, and it seams to work flawlessly.

 

I'm actually more concerned by the complete lack of new electronics smell.

I registered it OK, (so looks like it's not been done before) .

 

I know quite a few people return items, but the protective plastic is over all the scribble strips & screens, the USB is still sealed along with the usual cables etc.

 

I did think as I opened the cardboard outer box that is wasn't taped anywhere, but there were no marks where any tape might have been.

The branded Inner sleeve and inner box are completely unmarked, and there was a circular plastic seal tape that looked completely untouched on the inner box.

 

I'm probably being paranoid, It's not every day I spend more on a guitar effects processor than I did on my last car :)

 

 

 

Share this post


Link to post
Share on other sites
1 hour ago, PaulWilliamson said:

....

 

I'm probably being paranoid, ....

 

 

About what? The possibility that you weren't the very first person to unwrap it? It's working fine, there are no visible cosmetic imperfections, you have full warranty, ......  Relax.

Share this post


Link to post
Share on other sites
13 hours ago, silverhead said:

 

About what? The possibility that you weren't the very first person to unwrap it? It's working fine, there are no visible cosmetic imperfections, you have full warranty, ......  Relax.

I am simpatico with the OP here for 2 reasons. 1) smelling that new electronics smell when you first open the box and remove the plastic covers is part of the experience - especially when you’re opening something as significant and expensive as the Helix. 

2) It was sold as a new sealed item by the retailer. If the protective plastic strips and the smell of new electronics were both gone then to me it means that it had spent an inordinate amount of time outside the original packaging and been been used by someone. Carefully yes, but still used. It should have been sold as “B-Stock” at a small discount as a matter of principle. 

Share this post


Link to post
Share on other sites

Could be Line 6 pulls a few off the line for spot checking the lot after all the usual QA that goes one during the build and yours was one of those and the tester forgot to set it back to the default factory preset and power it off?

 

Share this post


Link to post
Share on other sites
On 4/6/2018 at 4:15 PM, PaulWilliamson said:

I'm probably being paranoid, It's not every day I spend more on a guitar effects processor than I did on my last car :)

WTF?  What car do you have? A 1980 Ford Fiesta? lol

Share this post


Link to post
Share on other sites

This discussion is 100% wasted energy.... you could live to be 1000, and you'll never figure out the truth. If it works, it works.  

Share this post


Link to post
Share on other sites

I agree... 100% wasted energy !

 

Helix cost me £1.199.00  ($1.689.11) at UK prices.. (US only 2 year warranty extension / US only special deals )

 

I was merely asking a question, if other people’s Helix Floors arrived in the same state, it would have put my mind at rest.

 

Enjoy your music.. 

P.S. My car is actually a 64 Ford Anglia 

Share this post


Link to post
Share on other sites
4 hours ago, PaulWilliamson said:

P.S. My car is actually a 64 Ford Anglia 

Love classic cars!  I am a longtime MG owner myself. Owned a 1973 MGB and a 1974 MG Midget.
Both cost around $3,000 to buy initially...and about a million dollars over the years in parts and upgrades (not sure what the automotive equivalent of "G.A.S." is lol).

Finally sold them off before I moved to Vegas 10 years ago. Didn't think they would be able to withstand 115 degrees Fahrenheit in the summers out here in the desert. 
I loved my Midget the best though. What fun it was to drive and tinker on. Before I was done with it I had personally installed a rebuilt over-bored 1275cc "A" series engine in it, put headers and a free-flow exhaust on it, changed it from a points ignition to a modern electronic ignition, and put a super charger on it. 

It was truly a "pocket rocket" and when you are going 110 miles per hour in that little go-kart...it's VERY exhilarating...lol  

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×