Jump to content
jwhitwell

L3t great on RCA inputs - every other input has noise/hiss when main volume increased.

Recommended Posts

I can run out of my iPhone straight into the RCA connections on the back, turn up main volume, and it sounds great when music plays, when music stops, very little noise at all.

 

When an input is applied anywhere else, however - either of the two side channels on the mixer, or on the main in on the back, turning up the main volume creates a hiss that isn't acceptable.  I've tried multiple mics, multiple guitars, different cables, etc - all the same.  Even when not even pushing a signal to the L3t, just having something plugged in to *any* input except RCA, and turning up the main knob - hiss.

 

This is too big and expensive to just be something that makes mp3's sound good, hehe.  Thoughts?  Thanks!

Share this post


Link to post
Share on other sites

One thing to check: what is the gain set to on the two mixer channels? I remember reading somewhere that if they were turned up even with nothing plugged in that you might get hiss. Something I need to check on my L2t’s

Share this post


Link to post
Share on other sites

Yeah, I thought of that early in the trouble-shooting process; both mixer channels are set to zero gain, didn't help.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×