Jump to content
Sign in to follow this  
ak4ray

Initial Impressions and suggestions

Recommended Posts

So I received my Powercab Plus Saturday and wanted to share a few things I've seen.

 

1) The cabinet seems very bass heavy, possibly something Line 6 can fix with a future firmware update, right out of the box I turned on the global bass cut on the back of the cabinet, everything sounded much better at that point, it cuts the bass by 80hz or something to that effect.

 

2) Output of the Flat preset seems to be fairly quiet compared to loaded IR's, go into the settings whether on the interface of the plus or via the powercab edit app and increase the level of the Flat preset to it's maximum +6.0db, again maybe this is something Line 6 can address via a firmware update as this setting seems comparatively quiet compared to the loaded IR's which all have their levels cut by something like 14.0db and when increased this thing get's pretty loud.

 

3) Run the cab at full output and adjust the volume via your modeler, also you may have to adjust the output of your patches to get a desirable volume level, I've been able to run it this way without getting a clipping warning from the input light on the cabinet.

 

I haven't tried my 3 Sigma or Celestion IR's but I would imagine I'll find similar results in level as the pre loaded IR's, this thing seems to be aimed at IR use or like I said maybe it just needs a few firmware updates before it see's it's full potential.

 

I hope this helps and if you have any suggestions please respond as I'm trying to figure it out as well :-)

Share this post


Link to post
Share on other sites

1) The cabinet seems very bass heavy, possibly something Line 6 can fix with a future firmware update, right out of the box I turned on the global bass cut on the back of the cabinet, everything sounded much better at that point, it cuts the bass by 80hz or something to that effect.

 

I think this is dependent on a number of factors. I have in some cases had many presets come off way to bright. There are so many variables at play. If I go from my SG to my Tele w/fralin p-90's there is a drastic change in tonality. This isn't one amp. It's many balled into one with a great variety of options. I imagine if your amp is on the floor and on carpet, that could also be a big factor. I don't necessarily think from my experience thus far there needs to be any changes (other than the slow start up time, lol)

 

2) Output of the Flat preset seems to be fairly quiet compared to loaded IR's, go into the settings whether on the interface of the plus or via the powercab edit app and increase the level of the Flat preset to it's maximum +6.0db, again maybe this is something Line 6 can address via a firmware update as this setting seems comparatively quiet compared to the loaded IR's which all have their levels cut by something like 14.0db and when increased this thing get's pretty loud.

 

My guess is that is a safety precaution because the flat setting is used for your own IR's housed on your modeler. The idea is that program will allow you to scroll through your presets on your device with cab emulation or IRs loaded and not having to change the speaker mode. 

 

3) Run the cab at full output and adjust the volume via your modeler, also you may have to adjust the output of your patches to get a desirable volume level, I've been able to run it this way without getting a clipping warning from the input light on the cabinet.

 

The way line 6 suggests is that you start with your device set all the way up and then adjust your amp volume. IDK which is right honestly, but that has worked for me thus far :)

 

 

Share this post


Link to post
Share on other sites
19 minutes ago, nathan217 said:

1) The cabinet seems very bass heavy, possibly something Line 6 can fix with a future firmware update, right out of the box I turned on the global bass cut on the back of the cabinet, everything sounded much better at that point, it cuts the bass by 80hz or something to that effect.

 

I think this is dependent on a number of factors. I have in some cases had many presets come off way to bright. There are so many variables at play. If I go from my SG to my Tele w/fralin p-90's there is a drastic change in tonality. This isn't one amp. It's many balled into one with a great variety of options. I imagine if your amp is on the floor and on carpet, that could also be a big factor. I don't necessarily think from my experience thus far there needs to be any changes (other than the slow start up time, lol)

 

2) Output of the Flat preset seems to be fairly quiet compared to loaded IR's, go into the settings whether on the interface of the plus or via the powercab edit app and increase the level of the Flat preset to it's maximum +6.0db, again maybe this is something Line 6 can address via a firmware update as this setting seems comparatively quiet compared to the loaded IR's which all have their levels cut by something like 14.0db and when increased this thing get's pretty loud.

 

My guess is that is a safety precaution because the flat setting is used for your own IR's housed on your modeler. The idea is that program will allow you to scroll through your presets on your device with cab emulation or IRs loaded and not having to change the speaker mode. 

 

3) Run the cab at full output and adjust the volume via your modeler, also you may have to adjust the output of your patches to get a desirable volume level, I've been able to run it this way without getting a clipping warning from the input light on the cabinet.

 

The way line 6 suggests is that you start with your device set all the way up and then adjust your amp volume. IDK which is right honestly, but that has worked for me thus far :)

 

 

 

Thanks for the response,  I'll have to try setting my helix to full output and adjust the volume via the Powercab.

 

And I'll also have to experiment with angling the cab and getting it off the floor as I had the coupling issue with the StageSource sitting directly on the floor in the past...probably the reason they put a bass cut switch on the back of the Powercab :-P

 

Thanks again

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...