Jump to content
Sign in to follow this  
Ramy6

Cannot go into factory reset mode

Recommended Posts

I just received my amplifi 75. Tried updating over bluetooth and update failed.

But I cannot factory reset the amplifier, I powered down the amp, pressed down the Master volume button and tone button. Nothing happened. I powered it down again and did the same thing for a minute nothing happened. I even kept pressing them for 5 minutes and nothing happened!

Is there a way around this is there something wrong I'm doing??

Share this post


Link to post
Share on other sites

If new, better to return it and get a working one..  Or, create a support ticket and get the ball rolling for repair.  I got a new one and it is in the "shop" still getting repaired for a similar issue.

 

Share this post


Link to post
Share on other sites

If this is a new unit, not a previously-owned one, it's unconscionable that it wasn't shipped with the latest firmware and required updating. 

 

As can be seen in this forum, updating these things can be very problematic, and it's clearly not a case of 'clueless users' who don't know what they're doing.

 

I'd suggest returning it to the retailer, if purchased new, or open up a support ticket. Hold their feet to the fire. Updating should not be this fragile a process.

Share this post


Link to post
Share on other sites

I got mine back on Monday. Apparently swapped the mainboard. Seems to be ok, I only had time to try the presets but not USB it to see what firmware, or use app.  before that I couldn't use it at all in any mode.

definitely contact support, or return and get a working one.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×