Jump to content
kruithof

Helix through FX return from JCM900 not working

Recommended Posts

Hi all,

 

Until now I used my helix through the FX return from a Lab L9 (solid state). Sounds great and works fine. However, if I connect the helix with my JCM900 in the same fashion, it does not make any sound, regardless how much I crank up the volume. Also, if I connect my guitar to the FX return of the JCM directly, there is no sound at all. If I connect the guitar to the regular input channels A or B, all works fine, so amp itself is ok. But when I connect the helix to either channel I need to crank up the volume considerably before it becomes audible and then also sounds mudded.

 

Questions:
- I would prefer using the FX return from the JCM as i do with the Lab L9. Is that doable? If so, how do I need to do that (if that is different than with the Lab L9)?
- Do I need to increase the output signal from the helix? If so, how do I need to do that?
- Do I need to increase sensitivity of the FX return? If so, how do I need to do that?
- Or is it likely that the FX return from the JCM900 is broken, since I do not seem to get any sound from it even when directly connecting my guitar?

 

NB I prefer not to use a 4cm method as I do not intend to use the pre-amps from the JCM.

 

Thanks for your suggestions.
Eric

 

Share this post


Link to post
Share on other sites

On some amps, the FX return is disabled unless something is plugged into the FX send. The first thing I would try is putting a dummy plug in the JCM900's send. Other than that, is there a switch for the JCM900's effects loop?

Share this post


Link to post
Share on other sites

I owned a JCM 900 years ago and from my recollection there really is nothing that you should have to do to use the FX return of the the amp. There is a level control for the loop, you might check that.

Share this post


Link to post
Share on other sites

Thanks all for your help.

 

Problem seems solved.

 

As suggested I put a dummy plug into the FX Send AND when also opening up the volume for the channel, it worked.

I would have expected the pre amps to be bypassed completely, but without opening the channel volume it does not work, were as it does ignore the channels eq?

Anyways it works and sounds great, so problem solved. Thanks guys for fast response.

 

regards

Eric

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...