Jump to content
Sign in to follow this  
GeorgeMarios

Helix Lt - Black Screen every time I launch Logic X

Recommended Posts

Hey guys,

 

Not sure if anyone has experienced this , but every time I have the Helix LT plugged into my computer (USB is plugged in order to use the HX editor, but device is actually running into my Daw through my saffire sound card) the Helix screen freezes and I have to restart it.

 

It is rather annoying and it has meant that I have been unable to use the Helix to record (or just about anything) so any help would be appreciated.

 

Cheers

Share this post


Link to post
Share on other sites

Check your controller setup In Logic X, one of them is sending data to the helix and crashing it.

 

Logic Pro X->Control Surfaces->Setup

 

Check the output port of every controller to find the one causing the problem and delete it or set its midi out correctly.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...