Jump to content

HELP! HELIX midi bug?? (Controlling Ableton and Mainstage)


kapaguitar
 Share

Recommended Posts

Hello fellow helix users. I got my helix roughly two weeks ago and it's an incredible unit! I'm loving it!

However, i'm experiencing some issues with using the Helix to control software.

I have helix controllers mapped out to certain functions of Ableton, some of them regarding the Looper and some of them regarding transport functions. 

It seemed to be working just fine and then some of the functions stopped working. 

For example:

The controller I had mapped for the undo functions would stop working (having working previously in the same song) and it also happened with the controller assigned to the  STOP function.

When I was very close to loosing my mind, I realised that for some reason, the Midi note assigned to the helix controller had changed!

Like I said, it happened with TWO different controllers more than once. 

 

So here's what i'm Doing:

 

In Ableton:

Helix Midi input: Track is on. Remote is on. 

Helix Midi Output: Sync is on ( for tempo synced effects) 

 

In Helix.

All the controllers are sending Midi notes Starting from the highest one (G9) downwards, all configured as follows:

Command: Note On

MIDI Ch: Base (1)

Velocity: 100

Note Off: Momentary

 

When the issue occurs, the Controller's MIDI note changes from whatever it was to C-1

 

Has this happened to anyone?? 

Can anyone help me out before I have a nervous breakdown ?

 

Thank you so much for your time. 

Link to comment
Share on other sites

What I'm seeing is that your controllers are not saved identically across all of your snapshots. For instance, in BASS ABLETON, using FS5 as an example, in Snapshot HW Clean, it sends A#8. In the other 3 snapshots it sends C#1. In CLEAN ABLETON, Snapshots CLEAN and HW CLEAN send A#8, but the other two send C#1.

 

Go through and make sure that all controllers in each snapshot in both presets are set identically. You need to save each snapshot individually before moving to the next one.

Link to comment
Share on other sites

I've found that, where snapshots are concerned, the logical assumption is usually wrong! Also... once you've got it working and thoroughly tested, SAVE backup copies, in case your working version gets a wild hair.....

Link to comment
Share on other sites

  • 2 weeks later...

@rd2rk I've been working with Helix and Ableton and have had no problems since your tip.

Thank you very much!

 

However, I have to use MainStage for a gig tomorrow and I've just realised something very weird is happening:

 

When Helix is connected to my computer, and i'm running the the concert (MainStage Session) that i'm going to use tomorrow, some midi controllers change they're notes temporarily...

 

Example: 

A controller that should be sending F#9 ( and that is actually saved like that across all of the snapshots ) changes to C-1 on 3 snapshots of that preset.

If I shut down the helix and restart it, it goes back to F#9... 

 

Any idea of what might be happening?

 

Thanks in advance. 

Link to comment
Share on other sites

When I was testing it for you, once I had the snapshots saved properly, no amount of random button pushing changed the messages sent. Of course, I'm not one of those machines that switch mfrs use to press buttons 10 million times.

 

If you're SURE that this is happening, and can reliably reproduce the behavior, get support on the phone and see what they think. I know that they're aware of some anomalies in the way that midi messages are handled in snapshots, maybe it's a known issue. It would be good if you could document the problem using a midi monitor, so that you could send a screenshot or text file for them to look at.

 

Good Luck!

Link to comment
Share on other sites

@rd2rk Thank you for the help.

 

These are different presets from the ones you've tested.

I live in Portugal, so calling Line6 support may turn out to be a bit expensive...

I'll have some time on Saturday and i'll try to register the data with a MIDI monitor, but for now, here's a video of what's happening:


https://www.youtube.com/edit?o=U&video_id=i0UfSzCQ-kE

( If it's still sideways it's because youtube is still editing it )

 

Link to comment
Share on other sites

@rd2rk Sorry for the late response mate.

 

I could trace the issue down to only two presets, which I've since deleted and replaced, and they seem to be working as intended. When you have the time do check the video, as it shows clearly the behaviour of the presets and it might be interesting for you on a curiosity level.

 

I've since installed a MIDI Monitor and realised that whenever I change presets on the HELIX, the unit sends out this message:

 

13:01:49.421    From HELIX       Control    1    Controller 61    0

 

even though I have the "Send Program Change" Option to Off in the Helix... is this normal?

 

Thank you for your time. 
 

Link to comment
Share on other sites

CC#61 is the Looper STOP command. Nobody knows why it's sent (I've asked). This MIGHT be fixed in the soon-to-be-released 2.6 update. Meantime, unless you've got something in Ableton set up to repond to that CC#, it shouldn't be a problem.

Link to comment
Share on other sites

  • 2 weeks later...

@rd2rk i wonder if you have any thoughts on the following:

 

I've been trying to use Ableton and Helix to create the ultimate live looping rigs, but have encountered many problems...

 

I have dedicated buttons on the Helix to:

 

Rec Looper 1

Undo Looper 1

Rec Looper 2

Undo Looper 2

Clear All Loopers

Stop All Loopers

Go to Previous Scene

Go to Next Scene

Launch Scene 

Stop Transport. 

 

The Footswitches are sending the following MIDI Note On/Off:

 

1:D9    2:C#9    3:C9    4:B8   5A#8

 

6:G9   7:F#9     8:F9     9:E9  0:D#9

 

I have successfully played a gig like this, but realised that i needed some improvements.

So i have "Select next scene on launch" active and I am trying to have scene Launch automate loop Overdubs and use dummy clips to automate preset changes on the Helix, and this is where the problems start!

 

Sometimes when launching a scene, the helix preset won't change, and ableton won't select the next scene.

 

I would assume this was an ableton issue, but i've realised that in this situation the helix controller footswitch light stays on permanently, and when it's a note on/off command the footswitch light should only be on when pressed.

 

Also, on some presets, sometimes the controller notes that i've assigned on the Helix change back to C-1 without my intervention... 

 

I am going crazy with this so if you could shed some light it would be very much appreciated. 

 

I have attached a faulty preset. 

 

Thank you so much

LEAD LIVE.hlx

Link to comment
Share on other sites

What you're trying to do is complex beyond my understanding of how Ableton works, but it sounds like either a timing thing, or something you're trying to do is canceling something else.

 

"I have successfully played a gig like this, but realised that i needed some improvements.

So i have "Select next scene on launch" active and I am trying to have scene Launch automate loop Overdubs and use dummy clips to automate preset changes on the Helix, and this is where the problems start!"

 

I'd start by going back to the version that worked, then adding features one at a time and testing thoroughly before adding changes until you get a fail.

 

Also, install the just released 2.60 update. They promised midi fixes and, although the release notes don't mention much, it could be that something was fixed "under the hood" that will help. Certainly, you don't want to get your problem fixed, then install the update and have it break your fix!

 

 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...